Jump to content
Corsair Community

Corsair Dock (TBT 100) randomly disconnects my mouse and keyboard!


Recommended Posts

I love the build and don't want to return it. But would like to try last time see if anyone can help me fix the issue.

Corsair Dock (TBT100) randomly disconnects my mouse and keyboard, and it is only limited to my mouse and keyboard (both Logitech) when plugged in the dock.

Here is the situations that I've tested: 

  • The issue only happens when at least one of the mouse and keyboard plugged in the docking station. When I use another hub to connect the keyboard and mouse to my laptop (Macbook Pro) directly, the issue is totally gone.
  • When the issue happens, my two HDMIs are working Ok, my laptop is still charging. Just keyboard and mouse are disconnected. I try to replug mouse and keyboard directly to the laptop and the dock, but doesn't work out. I almost feel like the dock station is particularly rejecting my mouse and keyboard.

Reboot, replug power supply of the dock or simply reconnect dock with my laptop can solve the problem. But the issue happens 4 to 5 times a day. Is there any known solutions to the problem?

Link to comment
Share on other sites

  • Corsair Employees

I love the build and don't want to return it. But would like to try last time see if anyone can help me fix the issue.

Corsair Dock (TBT100) randomly disconnects my mouse and keyboard, and it is only limited to my mouse and keyboard (both Logitech) when plugged in the dock.

Here is the situations that I've tested: 

  • The issue only happens when at least one of the mouse and keyboard plugged in the docking station. When I use another hub to connect the keyboard and mouse to my laptop (Macbook Pro) directly, the issue is totally gone.
  • When the issue happens, my two HDMIs are working Ok, my laptop is still charging. Just keyboard and mouse are disconnected. I try to replug mouse and keyboard directly to the laptop and the dock, but doesn't work out. I almost feel like the dock station is particularly rejecting my mouse and keyboard.

Reboot, replug power supply of the dock or simply reconnect dock with my laptop can solve the problem. But the issue happens 4 to 5 times a day. Is there any known solutions to the problem?

Hi,

Sorry to hear you're experiencing disconnects with your TBT100. I'll be converting your post into a support ticket, our team will help you troubleshoot.

Link to comment
Share on other sites

  • 4 months later...
  • 1 month later...

Hi there,

I have exactly the same problem, with a quite similar configuration: MacBook Pro (M1 Apple Silicon) and Logitech Unifyng UBS receiver.

In my case, not only the mouse and keyboard stops responding, also an USB SSD attached to the dock gets disconnected, giving the usual error message "disk not properly disconnected". Both HDMI screens remains connected when this happens, as the OP stated.

Was a resolution found for this? Should I RMA my unit?

Thanks a lot!

Link to comment
Share on other sites

Hi,

 

@Corsair Albert are there any Updates?

 

I have the exact same issue, randomly the Dock crashes and everything except HDMI stops working. I have Ethernet and audio connected as well.

Link to comment
Share on other sites

  • 2 weeks later...

Hi

I have the same issue as described above on an M1 Pro MacBook Pro 14", when using my Logitech G PRO X Ultralight Receiver on the dock, it randomly disconnects everything attached to the dock except for HDMI (USB DAC, Ethernet, USB Camera) multiple times per day. When using a Bluetooth Mouse directly connected to the Mac this issue does not occur.
 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...