Jump to content
Corsair Community

Corsair Sabre rgb Pro mouse setup


Starbruder
 Share

Recommended Posts

I bought the Corsair Sabre rgb Pro just yesterday. When it arrived today and plugged it in I was wondering that ICUE wouldnt pick my mouse up as a new device in the software. How can I get access to the controls etc.? (Windows recognized it too when I plugged it in my pc in a USB 3.0 type A port). I restarted my pc and updated the firmware of ICUE to the latest version available.

Link to comment
Share on other sites

  • Corsair Employees

Hi Starbruder,

Did you try plugging it in other ports? Even USB 2.0?

If that doesn't work try resetting your mouse with the following instructions.

1. Unplug the mouse.

2. With the mouse unplugged, hold down the left and right mouse buttons.

3. While holding down the mouse buttons, plug the mouse back into the computer.

4. After around 5 seconds, release the buttons. You will see an LED flash if it resets successfully.

If this still doesn't work, open a ticket with our support team and we will gladly assist with a replacement if needed.

Link to comment
Share on other sites

  • 2 weeks later...

Hi

I tried to firmware my sabre pro aswell. Now it doesnt work at all. Mouse is like deactivated. Nothing wotks anymore. And a computer qith no mouse is useless... i bought the mouse 1 day ago. It worked for the start but when i visited the corsair webpage and installed the firmware it didnt work anymore. Also tried the 5 second method. Didnt work... and im afraid that will happrn aswell with the keyboard.. i will send it back. I also tried to connect the mouse qith another computer but it didnt qork. Mouse is like dead20210903_200611.thumb.jpg.a53224427f9c6115f789db183f4faa63.jpg

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...