Jump to content
Corsair Community

Virtuoso wireless not working


Recommended Posts

The wireless mode isnt working any more after updating. Dongle and Headset blinking red all the time in wireless mode. Everything is at the latest version. I also de- and reinstalled icue, i did the repair option, different ports. I cant even initiate pairing the dongle any more, its greyed out. How on earth can u mess this up that much? last week, it worked perfectly fine - until the update. 

Link to comment
Share on other sites

  • Corsair Employees

The wireless mode isnt working any more after updating. Dongle and Headset blinking red all the time in wireless mode. Everything is at the latest version. I also de- and reinstalled icue, i did the repair option, different ports. I cant even initiate pairing the dongle any more, its greyed out. How on earth can u mess this up that much? last week, it worked perfectly fine - until the update. 

Hi Nihat0,

I have converted this into a Technical Support Request for your convenience -- the Tech Support team will be able to assist with your connection issues, and potentially send you a new wireless USB dongle here. Please keep an eye on your email associated with your Corsair account.

 

Thank you.

Link to comment
Share on other sites

18 minutes ago, Corsair Blade said:

 

Hi Nihat0,

I have converted this into a Technical Support Request for your convenience -- the Tech Support team will be able to assist with your connection issues, and potentially send you a new wireless USB dongle here. Please keep an eye on your email associated with your Corsair account.

 

Thank you.

 

Thank you very much, please be quick because I have to use wired right now. In addition, I formatted my computer and tried it on another computer, the problem persists.

Link to comment
Share on other sites

Having the same issue after firmware update. is the only solution to obtain a replacement dongle?

Link to comment
Share on other sites

after i updated iCUE to the newest version 2-3 days ago.
I can no longer use Wireless.
even my sound seems odd.
Did a formate and re-installed win on my m.2 SSD (was going to anyways,)
Nothing helped.
Try the 3.38 version of iCUE and then the latest, still nothing.
Try reset headset and do the reset fix with cables and dongle.
Still nothing.
Made a ticket, but well that will take 4-6 buisness days until responds will happen.

also, can´t force update on headset since it is greyed out.
And it wont even force update on the dongle.

pc spec.png

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...