Jump to content
Corsair Community

Scimitar RGB Elite - Side Buttons No Longer Work


Recommended Posts

I just purchased a Scimitar RGB Elite about a month ago and it has worked mostly OK. Sometimes keyclicks get "queued" and fire off 5 seconds after I clicked them. Eventually it will catch up and work like normal. This is an infrequent occurrence that I'm chalking up to the age of my PC.

I purchased this specifically because I was getting back into World of Warcraft with the release of WoW Classic TBC.

I used ICUE to set up keybinds and a special profile to activate when WoWClassic.exe is active.

This worked for about a month.

All of a sudden starting yesterday, I can't get the keys to do anything. I deleted bindings, changed profiles, restarted, updated, etc... but no change.

The profile is active (as the LED color I picked is lit up) - but no keybinds are making it through. Not in Notepad, not in a browser, nothing.

What can cause keybinds to not get recognized? Especially when they were working just fine the day before?

 

PC Specs (I know this is old, trying to hold out for AM5):

Intel Core 2 Duo E8400 @ 3.0Ghz
8GB DDR2-800
Nvidia GTX 750 Ti
Samsung SSD 850EVO 250
Corsair Scimitar RGB ELITE
Corsair K100 RBG (Optical)
 

Link to comment
Share on other sites

Additional Info:

Win 10 Pro x64 21H1 installed on 8/3 - no issues
2021-08 Cumulative Update for Windows 10 Version 21H1 for x64-based Systems (KB5005033) was installed automatically on 8/13... the day this all started.

Edited by Nokkan
typo
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...