Jump to content
Corsair Community

Dark Core Pro SE constantly "unavailable" in iCUE


Recommended Posts

I've changed the button assignment of the Profile Switch button under "Key Assignments" (not "Hardware Key Assignments" because that specific buttons seems to be disabled for reassignment there) to "Play/Pause".

assignment.thumb.png.64e023080c7c3258af1b97e2e1581ae5.png

The problem is that this doesn't work a good 90% of the time because the software refuses to detect the mouse and it shows up as "UNAVAILABLE", making the reassignment not taking effect (because it seemingly defaults to "Hardware Key Assignments").

unavailable.png.348dff8e7d53b6ab82b8cad0d7208f4b.png

I use the included wireless receiver, the switch on the underside of the mouse is switched to "receiver mode" (left-most setting) and the mouse generally does work as a pointer device and the buttons reassigned under "Hardware Key Assignments" also work as expected. A workaround that I've discovered is to connect the mouse via USB, open the mouse's device settings in iCUE and press the "Pair" button next to the label "USB Wireless Receiver Pairing" and then disconnecting the USB cable. This makes the mouse available and the button work again until an unknown event occurs or an unknown amount of time passes, I honestly can't tell which.

Here's a list of other workarounds I've tried without success:

  • Restarting iCUE.
  • Restarting the iCUE service under Settings.
  • Disabling the mouse's sleep mode entirely.
  • Changing the polling rate for both the mouse and the receiver.
  • Rebooting the PC.
  • Completely un- and reinstalling iCUE.

Here are the relevant software versions.

iCUE: v. 4.14.179
Mouse: v. 5.0.41
Receiver: v. 5.0.84

versions.png.3f8cee40cbd6e0c371e5843a72eca99a.png

Link to comment
Share on other sites

Since Corsair changed the downloads section of the software it is no longer possible to see what versions of firmware are the latest for each device. This is a massive oversight imho.

The only thing you can readily check is the iCUE version.

Many of the guides available on the Corsair website(s) are massively out of date and provide little or no help whatsoever this one is from February 1, 2018.......

https://www.corsair.com/uk/en/blog/DarkCore-Firmware

It would seem the most recent, aka relevant, guidance is this and I hope it helps. If not there should be a Corsair rep along at some point.

https://help.corsair.com/hc/en-us/articles/360025691851-How-to-Update-your-Dark-Core-firmware

How to: Update your Dark Core firmware

Keep your wireless Dark Core mouse up to date and running smoothly with the following steps.

What you'll need:

  • Dark Core RGB or Dark Core RGB SE wireless mouse with the battery charged
  • USB wireless transceiver dongle (included with your mouse)
  • USB charging/data cable (included with your mouse)
  • Computer with internet connection, running the latest version of iCUE

 How to update:

  1. Plug the USB dongle into your computer, preferably in the front for desktop computers
  2. Connect the mouse to your computer via the USB cable
  3. On the underside of the mouse, toggle the two switches to "ON" and "2.4GHz."
  4. Open iCUE and click on the "Settings" menu, found in the menu bar at the top of the window
  5. Click the mouse icon just underneath the menu bar
  6. Click the "Update" button next to the firmware version. iCUE will detect whether your mouse is up to date and download the update file if necessary.
  7. A warning button will appear after the download and installation is complete, click this to continue.
  8. Disconnect the USB cable from the mouse and toggle its power switch to "OFF."
  9. Disconnect the USB cable and USB dongle from your computer.
  10. Plug the USB dongle back into the computer.
  11. Toggle the mouse power switch to "ON."

The mouse should be usable at this point, and you should see the new firmware version listed next to the update button in iCUE.

 

Link to comment
Share on other sites

Hey, thanks for the reply.

As you said, I can't check if v. 5.0.41 is indeed the latest firmware for the mouse. At least iCUE reports that there are "No New Updates" so I suppose v. 5.0.41 is really the latest version available.

So yeah...Corsair? Anybody?

Edited by Retzudo
Link to comment
Share on other sites

I've had this same exact problem with my Ironclaw RGB wireless. I've been trying to fix this issue for 3months now and all Corsair told me to do was uninstall icue, force update mouse and dongle. The typical basic stuff which did nothing. On top of that they take forever to respond to emails. I get one response MAYBE once a week. It's absolutely ridiculous. I'm most likely gonna look elsewhere for a mouse/keyboard from now on.

Link to comment
Share on other sites

  • Corsair Employees
On 8/21/2021 at 10:48 PM, Snipe95 said:

I've had this same exact problem with my Ironclaw RGB wireless. I've been trying to fix this issue for 3months now and all Corsair told me to do was uninstall icue, force update mouse and dongle. The typical basic stuff which did nothing. On top of that they take forever to respond to emails. I get one response MAYBE once a week. It's absolutely ridiculous. I'm most likely gonna look elsewhere for a mouse/keyboard from now on.

Hi Snipe95,

 

I went ahead and looked into your ticket history for you -- it looks like we replaced the entire mouse for you early June. Are you still having issues after we replaced the mouse for you under warranty?

Link to comment
Share on other sites

  • Corsair Employees

I've changed the button assignment of the Profile Switch button under "Key Assignments" (not "Hardware Key Assignments" because that specific buttons seems to be disabled for reassignment there) to "Play/Pause".

assignment.thumb.png.64e023080c7c3258af1b97e2e1581ae5.png

The problem is that this doesn't work a good 90% of the time because the software refuses to detect the mouse and it shows up as "UNAVAILABLE", making the reassignment not taking effect (because it seemingly defaults to "Hardware Key Assignments").

unavailable.png.348dff8e7d53b6ab82b8cad0d7208f4b.png

I use the included wireless receiver, the switch on the underside of the mouse is switched to "receiver mode" (left-most setting) and the mouse generally does work as a pointer device and the buttons reassigned under "Hardware Key Assignments" also work as expected. A workaround that I've discovered is to connect the mouse via USB, open the mouse's device settings in iCUE and press the "Pair" button next to the label "USB Wireless Receiver Pairing" and then disconnecting the USB cable. This makes the mouse available and the button work again until an unknown event occurs or an unknown amount of time passes, I honestly can't tell which.

Here's a list of other workarounds I've tried without success:

  • Restarting iCUE.
  • Restarting the iCUE service under Settings.
  • Disabling the mouse's sleep mode entirely.
  • Changing the polling rate for both the mouse and the receiver.
  • Rebooting the PC.
  • Completely un- and reinstalling iCUE.

Here are the relevant software versions.

iCUE: v. 4.14.179
Mouse: v. 5.0.41
Receiver: v. 5.0.84

versions.png.3f8cee40cbd6e0c371e5843a72eca99a.png

I've gone ahead and converted this to a ticket on your behalf, so you can work with the tech support team to see if there are any potential software conflicts. Please keep an eye on the email associated with your Corsair account.

Also in preparation for tech support review, please run our Elgato Reporting Tool and have the .zip file ready to send back to support. Please see the link below:

 

How do I use the Elgato Windows Reporter utility? – Elgato

Link to comment
Share on other sites

4 hours ago, Corsair Blade said:

 

I've gone ahead and converted this to a ticket on your behalf, so you can work with the tech support team to see if there are any potential software conflicts. Please keep an eye on the email associated with your Corsair account.

Also in preparation for tech support review, please run our Elgato Reporting Tool and have the .zip file ready to send back to support. Please see the link below:

 

How do I use the Elgato Windows Reporter utility? – Elgato

 

Thanks, will do!

Link to comment
Share on other sites

  • 4 months later...

Has there been any further development with regard to this matter?

I've been having the exact same problem with my Iron Claw.  

Running 4.19.191 and I have already tried the above suggestions....

I must say, with my entire build being Corsair products, I have had noting but frustrations from day 1.

Link to comment
Share on other sites

The Iron Claw Wireless seems to be a hold out on this issue. The other wireless mice corrected with a firmware update a few months back, but ICW issues with this still pop up. I don’t know of another workaround aside from popping the receiver off and/or toggling it to wired mode and then back. 

Edited by c-attack
  • Like 1
Link to comment
Share on other sites

  • 4 months later...

I am currently having this issue with my Dark Core SE, I have been using it wired and have tried another cord that I know works and still shows as unavailable, when I go to settings it gives a red power symbol for the mouse. I have updated firmware and updated the iCue software as well with no luck, I do have a corsair keyboard as well which works without any issues. Please advise if there is a fix to this, I have had the mouse for a couple of years now. Thank you.

Link to comment
Share on other sites

  • 1 month later...

has anyone found a fix for this? I have an ironclaw RGB, exact same issue and i even formatted my pc, updated the bios even. I know all my firmware is up to date, icue as well.
Please help

Link to comment
Share on other sites

I had the same problem and I did this. You will have to use another mouse to get this to work right. Click on your mouse in ICUE and go to your mouse. On the left hand side of the menu, go into the "Device Settings". Then under those settings click on pair under "USB Wireless Receiver Pairing". Follow the instructions on your other mouse and your wireless receiver will pair with your mouse. Hopefully this helps. 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...