Jump to content
Corsair Community

iCue 4 (4.14.179) fails to install showing Qt platform plugin error


PsYcHoKiLLa
 Share

Recommended Posts

As the title says, version 4 fails to install with the error shown below:

image.png.e083d8fe043cdf5349d491638710f936.png


This issue was shown in the previous version 4 software also. Version 3 does install but, when using the software for my HS60 headset, the microphone level is not shown as it is in reviews I have seen. Presumably version 4 should provide this function but I cannot get this to install.
 

If this plugin is required then why does the software not also install it as a pre-requisite?

I'm not sure why the installer was provided as a .msi either instead of just a normal executable.

The volume control on the headset also does not adjust the master volume in Windows, seeming to be independent. Not an iCue issue but just mentioning it in case that's something else iCue 4 would allow.

Edited by PsYcHoKiLLa
Link to comment
Share on other sites

FYI, Currently installed version is 3.38.61 but the same error was shown when trying to install iCue 4 without any version being currently installed.

Edited by PsYcHoKiLLa
Link to comment
Share on other sites

After searching I found this on the Microsoft support site, tried the fix but still get the same error, it's apparently related to Python plugins, so if Python is required, why is it not bundled in the installer?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...