Jump to content
Corsair Community

iCue - The reason I'm never buying a Corsair again.

Recommended Posts

So here's the deal. Corsair hardware? Great! Every single bit of corsair software I've ever come in contact with, including this site? Total trash.

I've had issues with the iCue software from literally the first time I installed it.
First issue: iCue just did not detect my mouse. Only after closing and restarting the app did it detect my mouse. Cool, no biggey, move along. Then I discovered that, that is a permanent problem. Literally every time my PC starts it has disconnected from my mouse and I need to do a song and dance to connect iCue to my mouse again if I want to make a change.

Second issue: Then the first firmware update came along for my mouse (I have an Ironclaw RGB BTW). So I click the update link, it downloads and then fails to update, no reason just "update failed". Ok. Well I can live without the update move right along. But then I get a prompt every time I start my PC that there's an update and after more than a year now I still haven't been able to do a single firmware update.

Third issue: This is the one that brought me here. So of course, maybe these issues will be resolved in new versions of the driver software. Well today I got a prompt that there is an iCue update. Great, let me go do that, fingers crossed this will be way better and more stable. I click the update link, it downloads, it installs and I get a prompt to restart my machine. I click "restart now", I restart, and I open my background app tray waiting for iCue to load so I can test it out.... and, yes, you guessed it, like magic, nothing happens. iCue doesn't start. I think, ok, maybe it just removed itself from my start up apps, I should just run it manually and see if I can set it to run on start up from there. So, I open my search and search for iCue, nothing. Hmm.... Corsair? Nope. I open add or remove programs to see if it's installed on my PC. Wanna guess? Yup, you nailed it. App is gone.

At this point I'm pretty sick and tired of the hell iCue has given me, so I go to the Corsair site to vent. I go to the forum page, click sign up and what happens? I get taken to a white screen that just sits there... After waiting the usual 10 seconds I hit F5. Awesome, it loads. Cool. I register and after confirming my account I'm logged into the site, sweet. So I switch tabs and go to the forum page. I hit refresh thinking the site will pick up my browser session. Nope. I have to log in again. Awesome.

Basically, I don't know who you guys employ as devs over there, but they have completely ruined the Corsair brand for me and I'm sure I'm not the only one.
Hope you make better decisions in the future. So long and safe travels cause this Corsair has sunk.

  • Like 1
Link to comment
Share on other sites

So I haven't bought a new mouse yet, obviously, I'm still stuck having to wrestle with my Ironclaw RGB's software. Which means I have to now download and re-install iCue. Great. So I went and downloaded the 750MB iCue file. Cool, a whole new version, version 4. After the install I open the app, hope and potential washes over me, iCue 4 doesn't just have a much nicer look to it, IT IMMEDIATELY DETECTED MY MOUSE!!!! WOW!
Armed with my new found hopes and dreams I proceed to click the update firmware button, the thing I've wanted to do for sooo long!
It tells me, close other hardware controllers, check. Don't have the mouse plugged in via a hub, have it plugged directly into your PC, check. Don't unplug during the update, promise I won't, pinky swear. I click the "Got it" button. Immediately it tells me, "update failed" and it disconnects from my mouse "No device detected". Tried that twice, both times, same result.

Worst driver experience ever.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...