Jump to content
Corsair Community

ICUE H150I ELITE CAPELLIX APPEARING AS "UNKNOWN DEVICE" WHILST FLASHING RED


Recommended Posts

my pc specs: 

asus rog stix b450f gaming mobo

ryzen 7 3700x

nvidia gtx 1060 3gb

corsair vengace 16gb ram

 

When i first started up the machine everything seemed to be working fine, fans spinning, rgb lighting and the pump itself was working perfectly. The pc booted up as normal and i installed icue.

I ran a firmware update on the device to ensure everything was up to date, but afterwards the device was appearing as "unknown device" with all 6 of my fans flashing red, including the pump.

As you can see in the picture below the pump is working just fine and I can also hear it when I turn the system on and off.

 

I have tried uninstalling and re-installing icue, repairing the program itself, removing the core from Bluetooth settings and scanning for any hardware changes, still nothing.

Also swapping usb cables from the mobo and checking everything is connected to individual SATA cables, i cant seem to find a solution.

The last thing I have done is update the BIOS system and try unplugging the power from the pump.

 

 

If anyone can help me out here it would be much appreciated !!

Daekon.

 

 

pump working.png

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...