Jump to content
Corsair Community

Corsair One Pro (first gen) no longer power on


Recommended Posts

Hi all,

One day my corsair one decided to not turn on anymore. No fan, no beep, nothing.

What I have tried:
1. Plugged power cable out and in, won't help
2. Change CMOS, won't help
3. Openned it up and plugged the power cable directly to the power supply, won't help

I don't know what I should do, I assume it's out of warranty by now (purchase Sep 2017) , and the thing is that it's quite a unique build, I don't want to bring it to a computer shop before consulting with you guys. I am in Singapore, which makes thing harder, I guess.

Any advice would really be appreciated.

Link to comment
Share on other sites

  • 2 weeks later...
  • Corsair Employees
On 8/7/2021 at 11:48 PM, intoth3rainbow said:

Nevermind... found out the issue, turned out it's the best outcome possible. The power cable was broken, changed to another one and everything worked like a champ.

Glad that it worked out!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...