Jump to content
Corsair Community

Turn off Vengeance RGB lighting when computer in sleep mode?


Johnson919
 Share

Recommended Posts

I have 64 GB of the Vengeance RGB mode but when PC is in sleep mode the lights stay on, which with 8 sticks can stay very bright. I resort to having to cover  my PC with at night with a sheet to block out the light. I would like to be able to set the lighting to turn off when PC is in sleep mode but can't seem to do this. I have read that you can turn off the "Enable full software control" setting in iCue but my version of iCue 3 (latest version) doesn't show this option anywhere. I downloaded iCue 4 instead but same deal, so reverted back to iCue 3 so at least my cooler is available. 

Any ideas how I can achieve this? Thanks.

Link to comment
Share on other sites

3 hours ago, Johnson919 said:

I have 64 GB of the Vengeance RGB mode but when PC is in sleep mode the lights stay on, which with 8 sticks can stay very bright. I resort to having to cover  my PC with at night with a sheet to block out the light. I would like to be able to set the lighting to turn off when PC is in sleep mode but can't seem to do this. I have read that you can turn off the "Enable full software control" setting in iCue but my version of iCue 3 (latest version) doesn't show this option anywhere. I downloaded iCue 4 instead but same deal, so reverted back to iCue 3 so at least my cooler is available. 

Any ideas how I can achieve this? Thanks.

The "hardware" lighting profile is what the ram is set to do when the PC is off. Just remove the profile under hardware lighting. 

Link to comment
Share on other sites

The method to doing this in CUE 3 is different than in CUE 4.  In CUE 4, it works like any of the other hardware lighting mode.  Delete the effect or set a static black.  

 

For CUE 3, you need to turn off "enable full software control" in the RAM settings.  This drops you into hardware mode.  Now set a static black effect for the RAM.  Go back to settings and re-enable full software control and you are now back in software mode.  The new static black disappears (hidden setting) and you can set up whatever lighting effect you want.  This will be active anytime the software is running.  The black/off will return when CUE Is not running or those soft off power states like sleep mode.  

 

Also note you can do quick blackouts of the entire system.  In CUE 3 this is instant lighting black from the top drop down.  In CUE 4 you make a "scene" with a static color and slide it all the way to the black side.  This is useful for overnight downloads and such and is a one click toggle on/off of the entire system lighting.  

Edited by c-attack
Link to comment
Share on other sites

17 hours ago, c-attack said:

For CUE 3, you need to turn off "enable full software control" in the RAM settings.  This drops you into hardware mode.  Now set a static black effect for the RAM."

Hi thanks for replying but like I said I don't see that option anywhere....

 

iCue3.png

Link to comment
Share on other sites

You are in the master settings for the app which shows as an overlay. There should be individual device settings over on the left which appears to be missing.
 

I also now see you actually have “Vengeance RGB” and not that you were being casual with the name for a later version. It’s possible those first edition RGB modules did not have a hardware mode at all. If so, you’ll need to put it into Instant Lighting black before initiating sleep mode and then uncheck when you wake. I suppose turning the brightness slider to off would create the same outcome.  The RAM has to stay powered on during sleep, so all you can do is change the current lighting effect. 

Link to comment
Share on other sites

1 hour ago, c-attack said:

You are in the master settings for the app which shows as an overlay. There should be individual device settings over on the left which appears to be missing.
 

I also now see you actually have “Vengeance RGB” and not that you were being casual with the name for a later version. It’s possible those first edition RGB modules did not have a hardware mode at all. If so, you’ll need to put it into Instant Lighting black before initiating sleep mode and then uncheck when you wake. I suppose turning the brightness slider to off would create the same outcome.  The RAM has to stay powered on during sleep, so all you can do is change the current lighting effect. 

Ok, I see, thanks for your advice, I'll just turn down brightness every night!

Link to comment
Share on other sites

  • 6 months later...

So you have to install software in order to turn off the lighting on the ram?  If my PC was in sleep mode, it would make sense but when it is powered off, these should not be lit up.  I just installed them this morning, I walk by the room and it is lit up and discover the PC is off and the RAM lighting is on.  
Guess I have to turn off the power strip as well.  

Link to comment
Share on other sites

  • 2 months later...
Posted (edited)

Disabling the hardware lighting also turns of the RGB when you close the iCue software. Shouldn't it work the same as the H150i Elite LCD. It turns off when asleep but the hardware lighting settings is what stays on when the app is closed. It says it in the description. So if I close the software the RGB will be off and the H150i Elite LCD still on, doesn't seem to make sense. I guess I will have to keep iCue running which isn't really a problem but I shouldn't be forced to just to get the RGB to work as intended.

Im using 

harware lighting.jpg

corsair gear.jpg

Edited by iiron_eagle
Link to comment
Share on other sites

Posted (edited)
8 hours ago, iiron_eagle said:

Shouldn't it work the same as the H150i Elite LCD. It turns off when asleep but the hardware lighting settings is what stays on when the app is closed.

The problem is a basic hardware issue related to how “sleep” works in Windows. When you enter sleep mode, your AIO and most other hardware is switched off, just like when you shutdown. However, sleep mode stores the current OS operational state in the RAM and thus the memory modules are still powered on unlike most everything else. There is no practical way to make separate power delivery for the RAM and it’s RGB lighting and that’s a tricky business to begin with. If you frequently use sleep mode, you need to choose between having the RGB going all the time in that state or forgoing the RAM lighting in HW Mode for a few seconds on boot and shutdown. Or in the alternative, don’t use sleep mode and shutdown instead. That will use less power and in these days of SSD and m2 boot drives, you’re not waiting long to boot up. 

Edited by c-attack
Link to comment
Share on other sites

12 hours ago, c-attack said:

However, sleep mode stores the current OS operational state in the RAM and thus the memory modules are still powered on unlike most everything else.

Ahh yes I didn't think if this, thanks you.

Link to comment
Share on other sites

Posted (edited)
13 hours ago, c-attack said:

If you frequently use sleep mode, you need to choose between having the RGB going all the time in that state or forgoing the RAM lighting in HW Mode for a few seconds on boot and shutdown. Or in the alternative, don’t use sleep mode and shutdown instead. That will use less power and in these days of SSD and m2 boot drives, you’re not waiting long to boot up. 

I wonder if there is a difference between using sleep and shutting down in terms of pump longevity. I just had to replace my EK 360 AIO as the pump failed 2 months short of 2 years so it was still under warranty. I replaced it with the H150i Elite LCD. I used sleep a lot and used variable pump RPM which was set to the CPU temp and I see now was not a good idea as it was in constant change.  There was no way to set it to the liquid temp as I have now with the fans. I do set the H150i pump on balanced as I haven't worked out if I can set it to variable based off the liquid temp.

EDIT: I still have a working H80i from several years ago that still works pretty good thanks to it's thick radiator. I hope the H150i can last as long 🙂

 

Edited by iiron_eagle
Link to comment
Share on other sites

No, not for the pump.  That is definitely off when in sleep mode.  The MB and RAM are on, and then there are specific additional settings for MB related stuff like USB ports.  This why your KB or mouse sometimes lights up in sleep mode as well.  

 

As for longevity of any piece of hardware, there are debates about whether there is more wear and tear (or risk of fatal malfunction) when powering the device on (generally highest risk moment for electronics) and the alternative of keeping it running all the time.  I don't have an answer for every item, but as a long time water cooling user I suggest powering off or sleep if pump/cooling system longevity is the main focus.  There are exceptions either way with extreme use (or non-use), but you don't need to keep the pump motor running to help.  Those devices are very well understood and they've had years and years to refine the efficiency.  

 

You do want to use water temp as the control variable for the AIO.  Corsair coolers use the name of the product as the coolant temp (H150i Elite Temp, etc).  Variable speed curves were just introduced for the Elite series last CUE update, but I have not experimented with it yet.  I prefer fixed pump speeds or clearly defined plateaus where the pump speed jumps immediately to a higher level at a specific liquid temp.  However, that has more meaning in custom systems with a higher number of components and longer flow route.  For a short length AIO system, pump speed is rarely a meaningful factor and you can pretty much set it for noise and leave it.  If you are torturing a high core count CPU, you can increase to max before hand to minimize coolant to CPU contact time.  

Link to comment
Share on other sites

  • 3 months later...

I have vengeance RGB SL and icue 4.xx - I've deleted all Hardware lights (HL) and just had my lighting effect (LE) on.

At first PC sleep the LE stayed on - but that was because the system was not restarted.

After restart it worked and now in sleep the leds are in HL mode so off.

PS: (There is no HL mode in icue for my ASUS MB - so I turned them off for sleep in ARMOURY CRATE )

And now every led in case is off during sleep 😇

cheers

Edited by nope_no_name
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...