Jump to content
Corsair Community

LL120 don't light up


Recommended Posts

Hi. Sorry for my bad English.

I've 3 RGB Fan: 2 LL140 and 1 LL120. The 2 LL140 works perfectly with the iCue software, but the LL120 does not light up (only spin). I've the node pro with the hub. If I put 1 (LL120) 2 (LL140) 3 (LL140) no fans turn on. If i put 1 (LL140) 2 (LL140) 3 (LL120) only the first 2 will light up. I've tried iCue software v.3 and v.4: same problem. I've also tried to connect only the LL120 to the hub, but it will not light up. I think the LL120 is not damaged, because If i connect it to a simple switch of my case ( see attached ) it will light up, but only static red.

Some Specs:

GPU: GTX 1080 Asus ROG

Motherboard: ASUS ROG STRIX Z270E

CPU: Intel Core i7-7700K

Win. 10

1.thumb.jpg.a6906ab0229eaa5925cb000c2acaf27a.jpg

Link to comment
Share on other sites

There is a problem with the LL120. The RGB on most of these controllers is serial, so a bad LED or fan will affect anything further down the line. I don’t know what the specifications are for that switch, but I would not connect any more Corsair fans to it without being sure.

 

Contact Corsair Support to see about a replacement for the LL120 or use any local replacement options available.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...