Jump to content
Corsair Community

Corsair QL120 Stuck LED


Recommended Posts

Hey Corsair Community,

 

I seem to be having a problem with my Corsair QL120 Fans.

 

I have them set to all white in iCUE and it's been working perfectly until one day one of the fans had a LED stuck on purple. I tried everything that I could to fix it but couldn't. I RMA'd it for a new one and that was a success. Now another two of my fans are now having the same issue.

 

Has anyone else got this problem? Would anyone know a fix or am I looking to RMA the fans again?

 

See attached photos.

 

Thanks,

Beauzinga

IMG_0071.thumb.jpeg.a46a7c317a6e02f49333d77af0d30378.jpeg

IMG_0078.thumb.jpeg.33930a0b641af611ebe31755e76e8935.jpeg

Link to comment
Share on other sites

  • 3 weeks later...
  • 4 months later...
On 12/4/2021 at 7:28 PM, Linyl said:

I had a similar situation. One led among my ten QL120 fans stuck on pink. Thanks to whomever suggested going to SETTINGS>APPS > Corsair ICUE>modify>Repair.  Wait and restart. This worked for me. 

Didn't work unfortunately. :(

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...