Jump to content
Corsair Community

Virtuoso RGB Wireless (USB Type CA)


Recommended Posts

Hello. I bought a Virtuoso RGB Wireless today and the problem arose almost immediately.

The problem is that when you connect headphones via USB Type CA, the sound is lost.

Namely, the sound is about 10 minutes, maybe 30, and then some kind of crackling begins, then a squeak and silence.

Restarting the headphones from wireless to wired solves the problem, but not for long.

I connected the headphones via the WiFi module and so far there have been no problems for more than an hour, but I'm more interested in working on USB Type CA, what is the problem with?

Through USB, in addition to headphones, I have a mouse and keyboard from Corsair.

 

Version iCUE: 4.12.214

Version Virtuoso RGB: 0.17.149

Version Virtuoso Wirelles Receiver: 0.16.80

 

 

Apologies in advance for my english. ;-)

Link to comment
Share on other sites

I will add: Today 07/03/21 the headphones worked almost all day without failures, before that I disconnected the mouse and keyboard from the USB 2.0 connector and connected them to USB 3.0.

I connected the headphones to USB 2.0.

In the evening, the system issued a message that the device (Headphones) is not working properly, there are not enough resources and the microphone first turned off, and then the headphones.

Restarting didn't help.

It only helped to reset it to the factory settings (Hold the microphone mute button for 15 seconds), but after 10 minutes the problem repeated itself.

To be honest, I'm already pretty tired of these "dances", what's wrong with your headset, Corsair?

 

At the moment, I connected the device to USB 3.0, disconnected additional devices in the "Device Manager" and wait, wait for the next problems with the sound - hiss, popping, squeaking ...

Can anyone help me with solving this problem? Premium headphones shouldn't work that way, because I didn't give $ 10 for them in the end.

corsair-v.png.87b014bf3b1c5811dea65174ace08469.png

Link to comment
Share on other sites

  • Corsair Employees

Hi User_1234,

 

Sorry to hear you're experiencing this issue. Would you be able to force a firmware update to your VIRTUOSO and see if it helps?

 

I also suggest making sure you're not connected to a hub/dock. Trying a different cable/USB port may also help if you haven't done so already.

Link to comment
Share on other sites

Hi User_1234,

 

Sorry to hear you're experiencing this issue. Would you be able to force a firmware update to your VIRTUOSO and see if it helps?

 

I also suggest making sure you're not connected to a hub/dock. Trying a different cable/USB port may also help if you haven't done so already.

 

 

I can try to update the firmware forcibly if you tell me how to do it.

I want to inform you that the headphones are connected directly to the PC, without concentrators and hub stations.

I use the original USB cable (included with the headphones), I have not tried to use another USB cable.

Link to comment
Share on other sites

You can force update by following the steps below:

 

  1. Select your VIRTUOSO headset in iCUE
  2. Navigate to Device Settings
  3. Click "Check for Updates"
  4. Click on the vertical 3-dot button for more options
  5. Select "Force Update"

 

 

I did everything exactly as you said.

A forced update is not available, that is, I cannot press it, it is grayed out.

Link to comment
Share on other sites

Please update your iCUE to 4.13.223 - the option should be available then.

 

 

 

 

I have iCUE version 4.13.223 installed, but the "Force update" button is available (clickable) only for the mouse and keyboard from Corsairs, for Virtuoso and Virtuoso Wireless Receiver the "force update" button is not available.

Link to comment
Share on other sites

  • Corsair Employees

I suggest performing a clean installation of iCUE and reinstalling the latest version to check if the option to force update is re-enabled.

 

If the clean installation does not re-enable force update, then please open a ticket at https://help.corsair.com, our support will look into this and provide assistance.

Link to comment
Share on other sites

I suggest performing a clean installation of iCUE and reinstalling the latest version to check if the option to force update is re-enabled.

 

If the clean installation does not re-enable force update, then please open a ticket at https://help.corsair.com, our support will look into this and provide assistance.

 

A clean install did not help activate "Force Update".

I left a request on your advice to the Corsair support service.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...