Jump to content
Corsair Community

Corsair virtuoso rgb randomly disconnected


Recommended Posts

Hi. So I bought a pair of Corsair virtuoso from a store that I've now given them back the headphones to test it for issues. They recommend me to write and see if this is an known issues for this product or if it might be caused by something different.

I'm on the latest windows. I've teied to put the dongle in all other USB ports in north my pc and my laptop. Have the same isso on both computers. Totally random disconnect that won't reconnect until I restart the device and sometimes I need to put out the dongle and put it back in.

What may be causing this? Thanks

Link to comment
Share on other sites

  • Corsair Employees

Hi sverre_b,

 

While I cannot concretely say what the cause may be, there a few potential solutions.

 

  • Force firmware update on the VIRTUSO and its dongle
  • Re-pair the VIRTUOSO to its dongle
  • Perform a soft reset on the VIRTUOSO

1. Make sure your headset is currently unplugged.

2. Make sure your headset is powered on.

3. Hold the Mute button on the headset down for about 15 seconds.

4. Switch the headset off and then back on.

5. Test your headset and see if the issue is resolved.
Link to comment
Share on other sites

  • 1 year later...

Hi 

I have the same probleme here, i soft reset my headset but a day after the probleme continue, and i can't re-pair the dongle because its not working on the software so i don"t know what to do 

so if you now other fix it could help me.

Thanks

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...