Jump to content
Corsair Community

Odd (annoying) problem with ICU and Elite Capellix


Recommended Posts

I have 3 RGB fans that came with my H150i Elite Capellix, as well as the commander core. Now all ports are powered.

 

Now fans 1, 2, and 3 are plugged into the respective RGB hub ports, 1, 2 and 3. For whatever reason, whatever port fan 2 is plugged into, does not let it light up, and the other 3 ports not being used do not light up as well. Here is where it gets tricky...

 

If I plug fan 2 into an already lit up port (Fan 1 or Fan 3's RGB port), the fan lights up just fine, but ICUE still doesnt recognize it. Now if I force update the Capellix on ICUE the ports change and whatever is not used as well as whatver Fan 2 is plugged into bricks.

 

To be clear, I am strictly talking about the RGB hub on the commander core.

Can anyone help me out here?

 

 

Edit:

I have tried uninstalling and reinstalling numerous times.

The commander core is plugged directly into my motherboard( I have already switched around the USB ports it is in, to no avail).

Before yesterday I have had this issue. Yesterday evening I had messed around with the fans, and all 3 were working fine. I then tried to download an audio responsive wallpaper on wallpaper engine and it started having this issue again.

Edited by Ajaxx
Link to comment
Share on other sites

If my computer is on, am I not able to hot swap the RGB hub cables to different ports? I was afraid that the problem was my CoCo or software since ICUE didnt recognize the fans until a forced update, and that the other ports that were not in use did not light up immediately when hot swapped
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...