Jump to content
Corsair Community

Virtuoso Wireless RGB SE


Recommended Posts

Hi all,

Got hold of a pair of these recently and I like them a lot, apart from a pretty major issue i'm having.

 

It seems the functionality of the mute button on the microphone has a mind of its own. The Mic off/on, and Mic feedback off/on functions will trigger sometimes even if I simply brush on the microphone head, and almost always if I adjust the boom. Sometimes even if I grab the cups to adjust the headset on my head that will also trigger functionality of the mute button.

 

Of course, this also means the damn thing switches itself off quite often too (holding the mute button down).

 

It's happening when in USB mode and also in wireless mode.

 

Sound quality, charging, and all other functions seem normal.

 

I'm on the latest iCue 4.12.214, and the firmware is supposedly the latest for my dongle (0.16.80) and also the headset (o.17.149). iCue won't offer any firmware updates and 'force update' is greyed out and can't be clicked.

 

It's almost as if the static or an electrical leak in the device is making it go haywire on the mute button or something?

 

Also sometimes when plugging in the usbC cable it does the same, but many times in a row. I just tried it now and once plugged in via usb it proceeded to mute and unmute the microhpone, and turn on and off the feedback about 3 times each, in a row. Mental.

 

Anyone had this behaviour before? I've seen spare booms on ebay for not too much money so might be willing to try that if support don't get back to me soon.

 

I don't have a receipt for these so warranty/guarantee probably won't help me.

 

These Virtuoso seem riddled with problems don't they.. hmm

Link to comment
Share on other sites

Im also have a problem with my virtuoso, My dongle is saying Firmware V.?

 

Will not work wirelessly, its only 5months old and extremely disapointed. at a £150

 

Sent an email to support no responce within 10 days, i need a firmware sending over ino

Link to comment
Share on other sites

  • Corsair Employees

Sorry to hear you're experiencing this issue, MegaTonks. How is the headset's behavior with the microphone detached?

 

Im also have a problem with my virtuoso, My dongle is saying Firmware V.?

 

Will not work wirelessly, its only 5months old and extremely disapointed. at a £150

 

Sent an email to support no responce within 10 days, i need a firmware sending over ino

 

Your issue is different from OP's - I'll be messaging you for more details.

Edited by Corsair Albert
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...