Jump to content
Corsair Community

VOID ELITE WIRELESS not working


Recommended Posts

Hey there! I have been having an issue with my headset I have been using. I have a Void Elite Wireless headset, and I love it, but recently I tried to do an update for it but I had to cancel it during the update and then for some reasons it has not worked since.

It says it is up to date now, and I have tried everything to fix it from uninstalling the drivers and uninstalling icue and reinstalling it, with new drivers but it just wont work. it shows that it is connected and it powers on and the RGB works, but just no sound or mic.

I was getting this yellow exclamation mark before, but it didn't say what the issue was, and when I installed the latest icue it turned into a red power icon

if anyone could help me that would be greatly appreactied.

 

I included and attachment of what I'm seeing with my headset.

icue.PNG.ee8c799dc6d09e5942ef50cdd5879275.PNG

Link to comment
Share on other sites

nevermind, i finally figured it out. some how the dongle got disconnected from the headset and wasn't pairing anymore. i found the hole on the dongle and was able to reset it and establish a connection again to my headset
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...