Jump to content
Corsair Community

H100i RGB Platinum SE not working


Recommended Posts

Hi I’m having a problem with my H100i RGB Platinum SE AIO cooler. I bought it mid May 2021 and it was running fine in my PC up until yesterday. Right now the AIO pump doesn’t have any RGB on and the pump isn’t running. Within 2-3 minutes of the PC being on, the CPU reaches temperatures of 80-90°C. Also the two fans plugged into the provided PWM splitter run at full speed.

 

I’ve tried:

Restarting the iCUE software

Re-installing the iCUE software

Checking the SATA connection to the PSU

Checking the 4 pin connection to the CPU_FAN header

Checking the Micro-USB to the USB internal header

 

Additional Info:

 

The micro-usb off the pump head is connected to a USB internal header hub (hub goes to the USB 2.0 internal header on MOBO).

I know the USB internal header hub is working fine because I have a Node Pro and Node core plugged into it and they both show up in iCUE.

 

I tried plugging in the Micro-USB to USB header directly to the MOBO and still have the same problem (no power/RGB).

 

The SATA cable coming off the pump head is going to a SATA cable on the PSU that has nothing else plugged into it (Node Core and Node Pro are plugged into a different SATA cable).

 

When the RGB connectors for the fans are plugged into the splitter they don’t turn on (RGB for the fans work fine when they’re plugged into the Node Core).

 

I’m just wondering if there is anything else I could try. It seems like my only option left is to see if I can RMA it. I would like to avoid that if possible because I don’t want to be left without a working PC for too long (I will if it’s my only option).

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...