Jump to content
Corsair Community

Bad write performance on 250GB Force MP510 NVMe


Recommended Posts

Hello,

 

Like others here I'm experiencing bad write performance on my 240GB Force MP510 system NVMe:

 

attachment.php?attachmentid=41516&stc=1&d=1623853368

 

I've already disabled Fast Boot and checked the PCI power management option on my Z490 mobo. The SSD is about 4 months old. I didnt keep any benchmarks but I dont remember the performance being that bad when I first got it. I ran these benchs as I installed a second NVMe that is supposed to be an entry-level DRAMless drive but it ended up trouncing the MP510...

 

Any suggestions besides an RMA?

 

cheers

CrystalDiskMark_20210616161402.png.8f3014ebe09764da0ac6e24b0834405e.png

Link to comment
Share on other sites

  • Corsair Employees

Hi __valerian,

 

Have you tried performing a secure erase of the drive with our toolbox? I see you are using it as a boot drive currently but would recommend backing up all important data and doing so.

 

Also, you may use our toolbox to check if the drive is on the latest firmware revision.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...