Jump to content
Corsair Community

icue/Armory Crate update problems


Recommended Posts

Hey peeps, I'm having the same issues as some other users after the update from Asus Armory Crate. Prior to this update everything was working as it should, but now my icue software shows my fan RPM at 0 regardless of what profile i apply to the fans. They are both spinning and when I change the profile from quiet to extreme I can hear the fans increase speed but theres no change in the RPM reading.

 

Also, prior to the update the pump was set to quiet (I was told previously that if the cpu temps were under control then there was no need to run it faster as it would only contribute to the pump dying prematurely), but the pump RPM on quiet is now running at 1400 RPM which I've seen other users say is too low. When I change the pump profile to extreme I can't hear an increase in pump speed which I previously could, so this is leading me to believe that 1; the pump speed isn't changing and 2; the pump speed being shown isn't to be believed especially as in Asus' DIP5 the AIO pump speed (which is where the pump is connected) is showing between 1042 - 1090 RPM.

 

I also have a corsair lighting node with 2 LL fans which are being controlled though icue with no change after the update.

 

So far I have uninstalled Armory Crate and followed the 'clean reinstallation instructions' listed here https://help.corsair.com/hc/en-us/articles/360025166712-Perform-a-clean-reinstallation-of-the-Corsair-Utility-Engine-iCUE- But i'm still getting the same result.

 

I have tried the above method with the latest version of icue v3 and the previous version I was running before the Armory Crate update which was 3.20.80 and the issue still remains.

 

I also have a Corsair RGB strip which which never showed up in icue but which i controlled though Armory Crate but that's happlily 'Rainbowing' away without anything to control it.

 

My CPU temps are idling around 40-46c with the H80v2 temp around 34c.

 

PC Specs are:

 

ASUS ROG Strix X570-I Gaming

AMD Ryzen 7 3800x @ 4.2ghz

G.Skill Tident Z Neo 16gb x2

WD SN750 1TB

MSI RADEON RX 5700 XT

 

Any help on this and how I can restore functionality would be greatly appreciated.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...