Jump to content
Corsair Community

Corsair Scimitar Elite RGB Mouse acceleration

Recommended Posts

No idea how to start this but whatever here it goes.


I don't know if its iCue or the mouse itself, but everytime I plug it in and open the iCue software it turns mouse acceleration on, I double check if it's actually in my windows settings or in the software settings but it's always off in both.


Now here's the even more annoying thing, I have logitech mouse aswell that I use for shooters etc. and after having iCue open and the the Corsair mouse plugged in my logitech mouse ALSO has mouse acceleration turned on.


Closing the program and unplugging the corsair mouse doesn't help and I have to restart my computer with the mouse unplugged and the program closed to make the mouse acceleration go away. I made sure to close other programs that could conflict with iCue but that didn't help.


In short, I will send this mouse back if there is no way to turn off this horrible automatic mouse accel that applies to all devices somehow.

No it isn't just a feeling I measured the travel distance before anyone thinks about commenting on that.

Link to comment
Share on other sites

Which version of CUE 4 are you using? This was a problem with early releases and the enhance pointer precision would default to on the and the slider set to max in the mouse device settings (CUE). However, I thought it was corrected a little while back and all of my mice now default to the off and center slider position expected.
Link to comment
Share on other sites

Ok, I assumed you were using CUE 4 because this was a definite issue on the first releases. I never used the 3.38 version and need to get someone else to verify the state of things. That was the last issue of CUE 3, so if that is a bug in there, it may not be resolved.


I know this is now fixed in CUE 4, so updating is an option. 4.12 is a good place to start for most users as things are settling down. However, this is still device dependent. Take a look at the unsupported list. Also users with Commander Pro devices will need to re-program their fan lighting effects as of now.



Link to comment
Share on other sites

Ok I uninstalled 3.38 and moved to 4.12 which seems to have fixed the acceleration issue, I wasn't even aware a completely new version existed so thank you.


What's funny though was 4.12 set my pointer speed to max in windows so 800dpi felt like 3000 lol, kinda weird but at least everything works how it should now so thank you.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...