Jump to content
Corsair Community

K57 + Harpoon cannot connect simultaneously


Recommended Posts

I had a Logitech - G.Skilll mouse with a non-gaming Logitech keyboard with 2 dongles.

 

When the K57 arrived I tried to swap out the non-gaming-keyboard for the corsair dongle and it didn't work. The device manager USB setting said "Insufficient System Resources Exist to Complete the API"

 

I wanted to eliminate the possibility that there was a conflict between Logitech G-Series and Slipstream so I bought a Corsair Harpoon.

 

Turns out that I can't get both the keyboard and mouse working at the same time.

 

Under no conditions can I seem to get a K57 and either of the gaming mice working at the same time.

 

I also can't seem to get slipstream multipoint working

Link to comment
Share on other sites

  • Corsair Employees

Hi alex.chesser,

 

Make sure you're plugging the dongle into the back of the motherboard USB ports instead of the front panel USB ports. Sometimes front panel ports don't provide enough power. Also make sure you have the latest version of iCUE installed, you will need it for at least the setup.

 

If this still doesn't work, open a ticket with our support team and they'll have more specific troubleshooting instructions for you and possibly replacement if needed.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...