Jump to content
Corsair Community

Ironclaw rgb wireless connectivity issues


Recommended Posts

Hello everyone. I bought an ironclaw yesterday and was working fine until I tried to update the firmware when I installed iCue. After that my mouse stopped responding although it is on with rgb and everything and is charged. It is not showing up on iCUE or windows (on windows it is shown as "Game mouse" instead of Ironclaw rgb wireless that was in the beginning).

I still get the dongle on iCUE though but every option is greyed out. I tried a fresh install of iCue, an older version of iCUe, a different PC but it makes no difference.

I'd like to add that i tried connecting my mouse to my mobile and it worked fine via bluetooth :biggrin:. But on computer it doenst work wired or wireless.

Imo something went wrong on the firmware update and the dongle upgraded and mouse got corrupted but i really have no clue how to fix it. Any help would be appreciated.

Link to comment
Share on other sites

  • 6 months later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...