Jump to content
Corsair Community

Can't rebind Scimitar Elite


Recommended Posts

Hello! So, I just got a Scimitar Elite mouse and installed the iCue software (version 4.11). I am also using the Corsair K70 keyboard along side it. And I am on Win 10. Keyboard seems to be working fine.

 

For some reason I cannot change the side buttons on the mouse (1-12) to any kind of keybind (trying to change the side buttons to use F1 through F12).

 

Only videos I have seen was from an earlier version of iCue; they talk about going to "actions" and changing them from there. But now I think it's under "key assignments".

 

When I go into where I choose the keybind, it just keeps defaulting to G1-G12. It will not recognize any key I choose. I've tried using my physical keyboard and I have tried using the virtual keyboard.

Link to comment
Share on other sites

Try doing a quick repair install. Windows Settings -> Apps -> Corsair iCUE. Click on in and select modify, then follow the prompts for the repair install. Most often when the mouse will not execute its assigned functions or the buttons do not register, there is some type of installation corruption.

 

If this is a reoccurring problem or immediately comes back, then there might be another program interfering. Difficult to say what that might be, but obviously other KB/mouse control programs would be the first to check.

Link to comment
Share on other sites

Yes. It was another program interfering. My software for my previous mouse was the culprit.

 

Uninstalled iCue 4 and the other software and reinstalled iCue 4. It is working prefectly now.

 

Thanks for the insight on this.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...