Jump to content
Corsair Community

HS70 PRO Wireless stopped working after firmware update


Recommended Posts

Hello,

 

I have encountered the same problem as hundrets of other customers of Corsair as well.

 

I updated the firmware on my Corsair HS70 PRO Wireless which I bought a few weeks ago. Right after that, my PC stopped recognizing it and I could not turn it on anymore. The PC only recognizes the dongle stick.

 

Here is what I have done so far:

- Tried to soft reset the headset - did not work

- removed the dongle from the audio tools via windows - still did not work

- left the headset for two days in order to discharge the battery and tried plugging it into the computer via USB cable - did not work

- tried to pair the dongle with the headset again - guess what? did not work

 

Now, after researching, I found out that this problem is known by Corsair employees since at least 2015. So I have two questions:

 

1. Why are you guys still selling a product with a known massive problem for almost 6 years?

2. Since I could not find a working solution to this problem in all the forums etc., how can we fix this for me ASAP?

 

Here is my ticket number: 2004341610

Link to comment
Share on other sites

  • 2 weeks later...
  • 5 months later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...