Jump to content
Corsair Community

DPI scaling stuck after using sniper mode


Recommended Posts

I have the Nightsword RGB mouse, and frequently use the sniper button on it to reduce my DPI. However, recently I have noticed that the DPI scaling is getting stuck after releasing the button. This does not seem to be a problem with the physical button on the mouse, as it releases with no issue. This leads me to believe it is a problem somewhere within iCUE itself.

 

Sometimes the issue results in the sniper mode not releasing until a second or so after I release the button, sometimes it gets stuck until I hit the button again or move my mouse around, and sometimes it just turns on by itself. Any help fixing this would be appreciated.

Link to comment
Share on other sites

  • 7 months later...

I have the excact same problem but with an m65 mouse. Only thing I haven't tried is getting an earlier ICUE build.

Current ICUE version: V4.19.191

I'll give an update if it worked.

EDIT:Not able to find a version earlier, all give me this version.

Edited by Rheiric
Link to comment
Share on other sites

same thing.  but I did notice something.  I have a m65 mouse.  if I exit the software completely and go with my mouse onboard memory, then the sniper button works like it should.  However, with the m65 mouse, not sure of others or older but the new m65 rgb ultra, it has a tilt function as well.  and so, when I exit the program, that function then does not work.  I also noticed though that for me games seem to get a bit laggy as well when I use the sniper button if the software is running.  does not have to be open, just running.  but again, if I exit the software, everything is fine other than the tilt function.  

 

also, to add, when I first used the mouse, I had an older Icue verion v3 something and it would not even find my mouse.  kept saying plug in device.  so had to download the v4 version.  

Edited by cad80_99
Link to comment
Share on other sites

this seemed to work for me, but i still get a lag spike after holding my button for 3 seconds it will lag for a second then be fine until i release the button then it will do it again after 3 seconds.  but work flawlessly if i exit the software2021-12-27.thumb.png.1d5d72f0939f91f927df1ac777e419f2.png

Link to comment
Share on other sites

On 1/15/2022 at 4:59 PM, Rheiric said:

I have the excact same problem but with an m65 mouse. Only

The thread below is the current issue and recently introduced. The original poster was affected by a different problem that was later corrected. Fortunately this one is slightly more manageable and a simple re-click of the sniper button will release the DPI shift and it only enters that state after an extended hold. The earlier bug was much more intrusive. 
 

https://forum.corsair.com/forums/topic/173995-my-m65-sniper-button-gets-stuck-after-recent-icue-update/#comment-1008310

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...