Jump to content
Corsair Community

Several Issues with Corsair Virtuoso RGB Wireless


Recommended Posts

Hi altogether,

 

i recently bought the Corsair Virtuoso RGB wireless headset because of the awesome microphone and reviews that are out there,...

 

but there are some issues that make me kinda sad and im not able to solve them,... i've seen the global thread to the "SE" edition, but i was not sure if i should post my issues there or not - so i decided to make a separate thread to not cause any confusion (they still are different products).

 

I will start with the issues, followed by what i've already tried to fix them and the version information at the bottom.

 

Issues:

  1. Default Device Format ALWAYS changes back to 8 channel, when the Headset is being turned on (from "sleep" or via the switch) - which screws up all open programs soundwise. i need to reboot Discord for example to have it work again, that is annoying because i dont realise it sometimes that it happened - and then other guys write me like why im not responding anymore... - also, sometimes i randomly lose connection which also seems to trigger that "change" in default format setting (every... time... the headset is "turned on"). but with the 8 channel that annoying white noise is there...
  2. Windows boot takes up about 20x times as long when the headset is turned on before windows has booted - if the headset is turned off it boots reaaaally fast ~1-2 seconds (the windows 10 boot circles) but if the headset is powered on beforehand, it takes 20-40 seconds (if not even longer!!!) to boot into windows 10.
  3. Even though i hear the information "Charging complete" the battery status is set to "high" at most, never been "Full" +
  4. I've never ever reached the ~20 hours of battery life, and i have it about a week now. 14hours at most - with DEACTIVATED leds.

 

What i have tried:

  1. I have seen and tried the Soft reset. i also tried the mentioned "fix" for the white noise issue with the 8 channel set by windows. It did not help. I did force the update for the dongle - did not help either. (see versions below)
  2. I dont know how to fix it in any way
  3. Dont know either, i dont even have the microphone led active when the headset is not muted - do i have a faulty battery? (When i bought it last week - i followed the instructions and had charged it full before using it)
  4. Same here - just as today: before starting to work from home at around 9am i got the Audio notification that the charging is complete. And just now while writing this text (8:20 pm - so arround 11 hours later (!!!)) i receive the "Battery Low" notification - how is that even possible? do i have perhaps a damaged battery?? i dont get it...

 

Versions and Settings:

  • First i had the iCUE version 4.x installed. But since ive read on reddit and here in the forums that some user advise to use the more stable oder 3.x Version i switched to it, but in my case it did not do anything...
  • Softwareversion iCUE: 3.38.61
  • Dongle Firmware v.: 0.16.80
  • Windows is up2date (Win10 v.20H2)

 

i really do like the sound, and i rather dont want to return it, but if we cannot sort these issues out, i need to look for a more "stable" configuration.

 

Hope that someone hast any idea to these issues!

 

Kind regards,

arc0n

Link to comment
Share on other sites

  • Corsair Employees

Hi arc0n,

 

Sorry to hear you're experiencing these issues.

 

  1. Have you tried uninstalling the VIRTUOSO's drivers via device manager? They should reinstall after reconnecting.
  2. Not sure why it takes that long to boot up - but easily avoidable by not having the headset turned on when turning on your PC. Your system may be attempting to read it as a storage drive.
  3. If you're referring to the taskbar battery status, it's normal for the status to be "High"
  4. Battery life can be affected by various factors outside of RGB lighting: volume, wireless range, EQ settings

 

I suggest opening a ticket at https://help.corsair.com in the meantime if you haven't already - they'll be able to help troubleshoot and provide a replacement if necessary.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...