Jump to content
Corsair Community

Ironclad rgb wireless not being detected by iCue


Recommended Posts

I am having trouble and am awaiting responses from support for my Ironclaw rgb wireless mouse issues. After successfully installing icue 4.x I uninstalled it to try to fix a compatibility issue I was having with Asus Aura Sync ( an entirely exhausting issue in itself). In an effort to fix it according to some articles i read, I did a full uninstall of icue and clean install of ICue 3.xx which fixed my Aura issues but has left my Ironclaw completely undetected by icue. I tried reinstalling 4.xx but to no avail. Resets and clean installs later I am no where. I believe my firmware is either corrupted or rendered incapable of communicating with iCue. If anyone has had a similar issue and has found a fix please share. If anyone knows how to repair or install firmware on a mouse without iCue I would love to try it. Edited by marlomiranda
Typo
Link to comment
Share on other sites

This issue is resolved thanks to some savvy users in the forum.

Anyone that complains that this mouse will not be seen in Corsair iCue app can follow this exactly and it will work.

Corsair Ironclaw wireless RGB mouse not seen in iCue 3.xx either before or after using it with 4.xx The mouse cannot roll back the firmware to make it seen by iCue 3.xx after it is used with iCue 4.xx and in some cases may never be seen by 3.xx at all regardless. The long and short of it is if you cannot see this mouse in the iCue software, you will need to upgrade to the latest version of iCue which is 4.xx.

First: Uninstall the mouse and plug in any mouse to use in the meantime.

Second: Uninstall iCue and perform all of the steps included in the article “perform a clean install of iCue” to remove all traces of iCue in your computer.

Next: Install the Corsair Ironclaw Wireless RGb mouse without any iCue software.

Next: Download and install the most recent version of iCue 4.xx from the Corsair website

Lastly: Enjoy your mouse fully configurable from iCue 4.xx If you have installed v 4.xx and try to roll back to 3.xx your mouse will not be seen by iCue 3.xx. Once 4.xx is installed, it configures for 4.xx and removal of 4.xx and install of 3.xx will render the mouse unseen by iCue 3.xx which is the mistake I made. For those new owners of this mouse, beware which version of iCue you install first, if you don’t like 4.xx you are stuck using it until Corsair comes up with a workaround to roll back your firmware on your mouse without using iCue.

I hope this helps others, I was really frustrated but now it works fine.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...