Jump to content
Corsair Community

Sabre RGB Pro Bricked?


Recommended Posts

Hi everyone,

 

I just received my Sabre RGB Pro a few minutes ago. I set the DPI and everything in Icue and tried to update the firmware. ICUE said updated failed and now the mouse is unresponsive. I tried resetting PC, unplugging and plugging in the mouse multiple times and I can't seem to get it to work. Does anyone have a firmware file for it or is there a way to reset it?

 

Thanks!

 

EDIT: Called support and tried soft resetting by holding both buttons, plugging in mouse, waiting 10 seconds and releasing buttons. This did not work. They also said I am going to need to return the mouse to Amazon, but that seems like a waste of time because all I need is a firmware file. Does anyone have one available or do I really need to return the mouse?

Edited by Wartman
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...