Jump to content
Corsair Community

HS70 Pro sounds good in iCUE but terrible in anything else.


Recommended Posts

The other day my headphones broke so I decided to treat myself to a nice pair of headphones that were wireless.

 

As I have bad experiences with Wired headphones I decided to instead get a wireless pair and saw the HS70 Pro's advertised as crystal clear audio which was very visible when you listened through the iCUE sidetone.

But after I took apart the box and logged into a Discord call with some friends they noted that my voice sounded very low quality, I did the test and true enough it sounded awful.

 

At first I thought it was just discord (Which was the thing that was advertised to be crystal clear) so I tried it out on Teamspeak, it was still bad, so I moved onto Audacity, still bad, so I moved onto Windows Recorder, still bad. The only software I have tried so far that seems to output the audio decently is iCUE and Streamlabs OBS.

 

What I'm getting at here is that for some reason the audio that is output by iCUE or Streamlabs OBS sounds better than the stuff the hardware was advertised for. I really want this thing to be fixed cause I love the quality of the output and the battery life, especially since when I tested it on iCUE, I assumed that my outputs for all other systems would sound similar and have therefor disposed of the box and cannot return if it doesn't work.

 

#Note: I've already went from Sub-Reddit to Sub-Reddit, to different forum posts and have tried everything such as uninstalling the audio driver, setting the quality to DVD Quality or placing the connection into a different USB Port

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...