Jump to content
Corsair Community

How to unbrick Corsair H100i Platinum SE/solve USB disconnecting sound


Recommended Posts

I was trying to update AIO firmware through iCue when the update failed and bricked my AIO, AIO RGB went dark and it disappeared from iCue. I contacted support and got a series of instruction to flash the firmware after a week.

 

Following is Corsair support reply:

""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""

I'm sorry about your experience with our cooler. We may be able to fix it by flashing the firmware manually. Attached is the firmware file you'll need for this process.

 

The failed update was most likely caused by a conflict with another device or program using your USB Controller while the update was running.

 

Please unplug all USB devices other than Mouse/Keyboard/Cooler, and close all background tasks before starting any firmware updates. This includes any RGB Lighting, Hardware Monitoring, and Overclocking programs. A few examples are RGB Fusion, Aura Sync, Dragon Center, HWinfo64, Aida64, Ryzen Master.

 

Please be sure to follow this video guide step-by-step:

 

[ame]https://www.youtube.com/watch?v=oW9C8fxU72U[/ame]

 

If for any reason this fails, please disconnect the SATA power from the cooler and try again. If you have any questions at all, please let me know.

""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""

 

I tried to flash firmware after closing other RGB control and system monitoring programs, but failed to flash. Then I tried the reconnect AIO SATA method and firmware flashing worked afterwards!

 

Although I regained AIO control in iCue, I kept hearing the annoying USB disconnect sound. After a while the AIO RGB would freeze and would not respond to lighting change in iCue. I had to shutdown the system, boot up again to unfreeze AIO RGB (Restart did not work for whatever reason). Still hearing the USB disconnecting sound and AIO RGB freezed again after a while.

 

Then I found that it was having conflict with HWinfo, just disable monitoring on the AIO in HWinfo and the AIO worked normally under iCue control again (I disable "CPU" fan rpm under motherboard monitoring in HWinfo as well since it did not display correct pump rpm).

 

Lastly attach the firmware of Corsair H100i Platinum SE for those who do not want to wait for a week.

H100_PlatinumSE_V1.1r15.zip

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...