Jump to content
Corsair Community

K63 non stop issues.


Recommended Posts

It took months to get an RMA done for my K63 wireless and I was informed that the new unit wouldn't be covered in a warranty. Worked fine for a couple weeks then it started acting up. Went into iCue and it told me to do a firmware update. Followed the instructions and the update failed. I used a laptop to make sure i was using usb ports that weren't on a hub. Now the most i can get the keyboard to do is turn on with solid green led, 2.4ghz white led pulses once, then both turn off and keyboard is unresponsive. I've tried the reset button under the keyboard foot, and the holding esc/powering on reset. Anyone know what to do?
Link to comment
Share on other sites

  • Corsair Employees

Hi Ozzysite451,

 

Can you let me know your previous ticket number, so I can have the support team review it again and make sure you aren't still in warranty? I went to check for you but couldn't find an email address to cross-reference. Apologies for any inconvenience.

Link to comment
Share on other sites

Hi Ozzysite451,

 

Can you let me know your previous ticket number, so I can have the support team review it again and make sure you aren't still in warranty? I went to check for you but couldn't find an email address to cross-reference. Apologies for any inconvenience.

 

Any idea's of what to try?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...