Jump to content
Corsair Community

Corsair Virtuoso RGB White noise is gone but!


Recommended Posts

Hey i have done this stuff that Corsair Elito said in another topic.

The white noise is gone, But the problem is the 8 channel is now gone. is that ok?! It wont affect the headset in long term? ty.

  

On 4/12/2021 at 12:20 PM, Corsair Elito said:

Hi,

 

I would like to get some feedback on this fix and see if resolves your static issues on the Virtuoso.

 

PM me if you happen to remove the static or if this doesn't resolve the issue, thanks.

 

Please make sure:

 

1. Audio drivers are up to date

2. iCUE is up to date,

3. Disable spacial sound

4. You have tried a soft reset on the headset

5. Your audio is set to the highest quality in windows sound control panel

6. Make sure the setting is disabled:

Open Control Panel and select Hardware and Sound.

Click Power Options.

Click Change plan settings next to your current selected power plan.

Click Change advanced power settings.

Click the + button next to USB settings.

Click the + button next to USB selective suspend setting.

Click the setting and select Disabled.

 

 

To soft reset your Virtuoso headset make sure your mic is connected:

1. Make sure your headset is currently unplugged from the charger.

2. Make sure your headset is powered on.

3. Hold the Mute button on the headset down for about 15 seconds.

4. Switch the headset to wired mode and then back to wireless mode.

 

If this doesn't resolve the issue move on to the next steps.

 

 

 

On windows 10 called "Local Group Policy Editor." You navigate to it by typing "Edit Group Policy" in the Windows 10 Start Menu, then you will see the window. You need to navigate through the below branch.

 

Computer Configuration -> Administrative Templates -> System -> Device Installation -> Device Installation Restrictions -> Prevent installation of devices not described by other policy settings -> Enable -> Apply

 

From this, restart your computer, then navigate to device manager. Click on view, then "Devices by container." Go to your headset and uninstall the device.

 

Afterwards, restart your computer, and make sure you have the latest version of iCUE installed. You need to navigate back to the policy and set it to "Not Configured" or "Disabled." If you do not do this, you will be unable to install your drivers.

 

After doing this, you will navigate back to iCUE and force a firmware update.

Link to comment
Share on other sites

  • Corsair Employees

Hi,

 

It will not affect your headset, 8 channel will reappear if you reset the headset and it will default to 8 channel if you change it back to 2 channel, 8 channel will disappear again. It's a windows issue we aren't able to address at the moment. You should have not issues.

Link to comment
Share on other sites

  • 2 weeks later...
Hi,

 

It will not affect your headset, 8 channel will reappear if you reset the headset and it will default to 8 channel if you change it back to 2 channel, 8 channel will disappear again. It's a windows issue we aren't able to address at the moment. You should have not issues.

 

This is good. The white noise is 100% gone now! I am happy. ty

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...