Jump to content
Corsair Community

Dark Core Pro SE Dongle woes


Recommended Posts

-Updated to icue v4.10.237.

-Have a Corsair Virtuoso for several months that has been working fine.

-Got a Dark Core Pro RGB SE this week.

-Initally everything was working fine, dongle and dark core pro se mouse aswell as Headset and headset dongle all showing .

-Literally the day after i recieved it got a notificaiton through icue that said an update was available for my mouse and dongle.

-Update the firmware for both sucessfully, everything was showing as before and working.

-Mouse now shows firmware v5.0.41. Cant remember the dongle firmware and cant check it now for reasons detailed below.

-Went to sleep with pc turned off. Woke up and turned pc on, mouse not working, flashing white LED that manual indicated means it has failed wireless connection.

-Checks icue, dongle now no longer appears/has disappeared from icue, tried on diffrent usb ports and even on a sepperate pc with same version of icue to no effect, it does not show up.

-Windows doesnt even make the usb "chime" when it detects a new usb device.

-As such my "wireless" mouse cannot be used with the slipstream dongle.

-Been looking on this forum that suggest it may have somthing to do with slipstream multidevice? Or at least alot of issues have been caused by the "beta" despite icue giving no other warning that you cant flash the firmware back once its enabled? (At least thats what my Virtuoso is saying at the moment).

-Tried re-setting the mouse by unplugging, holding both mouse buttons, turning on ect. No effect, mouse firmware is still the same.

-Tried clean installing of icue v4 to no effect.

-Tried reparing with the usb cable plugged in and the mouse dongle, however the "start process" button remians grayed out.

 

Anyone else experiencing this? Any suggesting on how i can fix it?

 

Already had to RMA my mouse once for the same issue that i didnt realise was connected, which makes me feel remarkably stupid, however i had'nt looked on these forums untill after I'd done the firmware update again. I cant believe there isn't more of a warning that problems like this could occur with this firmware version, a suggestion you cant flashback isnt much of a warning that it could brick your dongle.

 

Was trying to see if the dongle still apeared in the device manager at all, but cant seem to see it, anyone know its name as it appears in device manager so i confirm its truly dead?

Link to comment
Share on other sites

  • Corsair Employees

Hi Cytex,

 

If the mouse works fine wired, but the dongle doesn't, our support team can potentially replace just the dongle for you. The best next step here would be to open a ticket with Support, using the "Support Ticket System" link at the top of this page -- from there, they can assist with a firmware reset as the first step, and then send over that dongle if applicable.

Link to comment
Share on other sites

Hi Cytex,

 

If the mouse works fine wired, but the dongle doesn't, our support team can potentially replace just the dongle for you. The best next step here would be to open a ticket with Support, using the "Support Ticket System" link at the top of this page -- from there, they can assist with a firmware reset as the first step, and then send over that dongle if applicable.

 

I think i actually submitted a ticket before i made this account, should i keep waiting on it, hav'nt had any confirmation or anything sent to my email yet, and my account of the corsair website doesnt show any pending tickets? I can appriciate given the current pandemic that the wait may be a bit longer but i have no idea if the automated chat even sent the ticket through?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...