Jump to content
Corsair Community

HS60 Pro Surround no longer putting out audio when plugged into usb dongle


Recommended Posts

Earlier today I was watching youtube then my audio suddenly stopped, I went into the windows audio settings and could no longer find the HS60 Pro listed anywhere. The headset was plugged into the usb dongle provided. I unplugged everything and plugged it back in, still nothing. BUT if I plug the headset directly to a 3.5mm audio jack I can hear things fine (in stereo).

Looking in iCUE shows me nothing, it doesn't even know that I have the headset plugged in, whether or not its plugged in thru the dongle or the jack.

Assuming that this was a problem with the usb dongle I went to device manager, in the USB controllers section there is an "Unknown USB Device (Invalid Configuration Descriptor)" which I know to be the dongle because if I unplug it, the Unknown device goes away.

I have tried reinstalling iCUE (both the v3 and v4) as well as repairing them via control panel, I have tried updating the drivers for the dongle but windows says the the best drivers have already been installed, I even updated my graphics drivers to see if that would help, still no audio from the USB dongle.

If anyone knows of a fix that would be great, this is my first time posting on this forum so if I need to be in a different forum please let me know.

  • Like 1
Link to comment
Share on other sites

  • 2 weeks later...
Nope, but I was messing around and something new has happened. Here's the steps to reproduce. Keep the dongle plugged in, then plug in JUST the microphone into the dongle. Wait a few seconds, then unplug the mic. Plug the headset into the dongle and you'll get audio through it. In device manager windows seems to recognize it properly but iCUE doesn't seem to see anything. It still only works in stereo, but it's something.
Link to comment
Share on other sites

  • Corsair Employees
I don't remember buying any warranty when it was bought off amazon, so I think I'll just have to buy the dongle individually here but it's always out of stock.

 

Our headsets carry a 2-year warranty by default when purchased from an authorized reseller - resellers may offer their own warranty program but that is completely separate from our's.

Link to comment
Share on other sites

  • 5 months later...

Did you ever got a replacement or solved your problem?

The same thing happened to me today. The sound card dongle decided to stop working after just 2 days of buying my headset brand new from amazon. Now I'm getting the same USB error in Windows device manager and can't use both audio and mic without the sound card.

Wrote Corsair support hoping to get some feedback or a replacement dongle soon

Link to comment
Share on other sites

  • 2 months later...

Currently experiencing a similar issue. Headset works properly when plugged into a 3.5mm jack. However, when plugged in the USB dongle; Windows recognizes the device as "Conexant USB ADAPTER". Microphone fails to works and audio is partially functional. 

 

Tried to look for drivers to manually install.

 

PS: Don't tell me to use the iCue software, because iCue will not recognize the USB DONGLE/Headset as a Corsair device.

Edited by Cmkluo
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...