Jump to content
Corsair Community

RGB Hub/Lighting Node Pro not detected/not working


Recommended Posts

Hey all,

 

I just finished installing three of the fans that came in the kit along with the Hub and Node Pro. After I installed everything, I powered the computer on with only a power cable, so no monitor/peripherals/etc. The fans began spinning and the RGB lights were illuminated. Assuming I had a successful install, I brought the PC back into the office and plugged everything back in, and booted up. However, now the fans only spin, and no lighting whatsoever.

 

iCUE is not recognizing any Hub or LNP, meaning it isn't even showing up anywhere in the iCUE software.

 

I have tried several reboots, unplugging cables and rearranging the order, checking the SATA connections, unplugging all of the computer's peripherals, unplugging the mobo USB pins and reconnecting them, with no results. I have the three fans in the Hub slots of 1, 2, 3. Does anyone have any info on what could be going wrong?

 

I'm inclined to think the Hub is not faulty because it was working and illuminated for several minutes without anything but a power cable, but when I did a hard shut down and rebooted with everything connected is when I began to experience problems.

 

Any help is greatly appreciated.

 

Quick edit: I have the latest version of iCUE and everything seems to be up to date.

Link to comment
Share on other sites

A hub and a Lighting Node Pro? This could be either ML-RGB fans or LL fans, however the problem is your Lighting Node Pro is not recognized in CUE. There is no "auto-detect" of your fan type, so when CUE loads for the first time you must go into the Lighting Set-up and designate LL x 3 fans or whichever is correct for your fan type and number. Before the software loaded you were in hardware mode and that is the normal response until CUE loads.

 

The RGB Hub will not be recognized and it supplies 5v power to the fans while the LNP is the controller and software interface. Since you have already done the basic SATA cable and other USB ports check, it is possible this is a chipset driver issue on your end. We don't see a lot of B360 owners with questions and I don't know the limitations of the board. Make sure you have the latest chipset drivers installed for your MB, but aside from that I would contact Corsair Support to see about getting specific MB help.

 

You might be able to keep the rainbow going if you set CUE not to run on start-up.

Link to comment
Share on other sites

Thanks for your reply, c-attack.

 

I did some snooping after this began and the chipset drivers to my motherboard are extremely hard to find/non-existent, but that's a different problem which I look into, maybe that will help.

 

However, when you mentioned that upon startup that the PC is in hardware mode, wouldn't the fans light up from initial boot, and then once iCUE loads is when they encounter an issue? Because as of right now, they never turn on, even from startup. Which is peculiar to me because they illuminated the first time I booted up after installation, but not since then.

 

As far as the iCUE interface goes, I don't have a lighting effects option anywhere. The only devices that appear are the HS60 Headset, Dark Core Mouse, and the Dark Core Dongle. I will attach a screenshot of my Home screen in iCUE.

 

I will continue searching for a chipset driver, in hopes that is the issue.

 

iCUE Screenshot: https://ibb.co/yQLF04p

 

UPDATE: I used a driver update program to update all out of date drivers, as well as disabling iCUE on startup, and still no luck.

Edited by darkagepulp
adding image link
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...