Jump to content
Corsair Community

ICUE 4.x Philips HUE Exclude certain rooms


Recommended Posts

  • Corsair Employees
If you think of each room as files you need to select its actually quite simple. CTRL+LeftClick the ones you wish to remove from the effect and it will only control the remaining lights you haven't deselected. If you wish to add them back in you just do the same thing and it reselects them.
Link to comment
Share on other sites

  • 3 weeks later...

Same issue. The problem is that when creating new lighting effects, it selects the entire house by default. Everything goes to spiral rainbow, including my outside lights.

 

I want to have the default be just the room with my computer. It looks like the develops did not consider the use case where someone is using one Hue bridge for their entire house.

Link to comment
Share on other sites

  • 2 weeks later...
If you think of each room as files you need to select its actually quite simple. CTRL+LeftClick the ones you wish to remove from the effect and it will only control the remaining lights you haven't deselected. If you wish to add them back in you just do the same thing and it reselects them.

 

I'm having the same issue. Selecting or de-selecting doesn't seem to do anything. I really like the Hue integration but it isn't going to work if it's either the whole house or nothing.

 

Can you advise as to the exact steps we should follow to de-select specific lights/rooms?

Link to comment
Share on other sites

  • Corsair Employees
I'm having the same issue. Selecting or de-selecting doesn't seem to do anything. I really like the Hue integration but it isn't going to work if it's either the whole house or nothing.

 

Can you advise as to the exact steps we should follow to de-select specific lights/rooms?

 

In the Lighting Effects menu with each room listed and the effect showing, you can now just click on the actual effect under the room to turn the room off. If you mouseover the little graphic that shows the current effect assigned to the room, it will outline in YELLOW, and then you can just left click it ON or OFF. It was changed from the CTRL+Click. You can also just go to the Quick Lighting Zone area and select what room you want on or off also.

Hue1.thumb.png.02d6f8fcf364e62918e2ae369f3119cc.png

Hue2.thumb.png.b562d479510813a44a7f7991307e67cd.png

Hue3.thumb.png.1d8c9765b8f57276299bdf3098aa84d9.png

Hue4.thumb.png.081fde52b56b83b0895720118804e612.png

Link to comment
Share on other sites

In the Lighting Effects menu with each room listed and the effect showing, you can now just click on the actual effect under the room to turn the room off. If you mouseover the little graphic that shows the current effect assigned to the room, it will outline in YELLOW, and then you can just left click it ON or OFF. It was changed from the CTRL+Click. You can also just go to the Quick Lighting Zone area and select what room you want on or off also.

 

Thanks,

 

Does that work when using a preset/scene though? All the options for room/zone control etc are hidden when using a scene. So if I choose a scene to have the same colour or whatever on my PC lights and Hue lights, I can't see any of the options to switch off individual Hue rooms/lights.

 

Am I missing something?

Link to comment
Share on other sites

  • Corsair Employees
The preset SCENES will control ALL RGB lighting devices. You do not have the option to turn off individual devices per SCENE. This is the replacement for the INSTANT LIGHTING feature in iCUE 3 and acts the same when it comes to controlling all RGB devices.
Link to comment
Share on other sites

The preset SCENES will control ALL RGB lighting devices. You do not have the option to turn off individual devices per SCENE. This is the replacement for the INSTANT LIGHTING feature in iCUE 3 and acts the same when it comes to controlling all RGB devices.

 

Ah, got it. In that case I guess I need to use Lighting Link to unify only selected devices? I'll try that later.

 

Per your explanation, I understand that the software is operating as designed. However, now that iCue is branching out to control devices beyond the confines of the local machine, the Scene/Instant Lighting behaviour might be worth a re-think. Or, perhaps better, is to have a global setting to disable control of certain devices (I think someone suggested that above).

 

Otherwise there could be lots of confused people who inadvertently get Rainbow Wave running all over their house.

Link to comment
Share on other sites

  • 1 month later...
  • Corsair Employees
This needs a fix ASAP, when I use link lighting the whole house lights change.

Want it in just one room.

 

If you are utilizing the Lighting Link effects you can indeed only set that effect to the specific room you wish to control. Unless you are referring to the new SCENES feature at which point unfortunately those effects do indeed control all connected RGB devices and does not allow for individual device control.

Link to comment
Share on other sites

No you can not, Even If you select a room, it will still light all lights in the house. You need to be able to Remove rooms in the software, as you can not.

Only way I can get it to not do it, is too ether turn the bulb off at the wall/mains or turn it off in the Hue App via phone.

Many other users have reported the same. Quick google and you will see. And this post here - https://forum.corsair.com/v3/showthread.php?t=205451

CTRL+LeftClick does not work.

If I set my system to link lighting it does not put a effect in the lighting on the Hue menu in iCue, even tho it control the bulbs. So how can you remove it? If CTRL+LeftClick even worked, it would not work here too. Add do you expect users to remove it every time they switch there lighting option.

I think you need to add remove Hue device option, this will make many people happy.

Edited by Strolla
Link to comment
Share on other sites

  • Corsair Employees
No you can not, Even If you select a room, it will still light all lights in the house. You need to be able to Remove rooms in the software, as you can not.

Only way I can get it to not do it, is too ether turn the bulb off at the wall/mains or turn it off in the Hue App via phone.

Many other users have reported the same. Quick google and you will see. And this post here - https://forum.corsair.com/v3/showthread.php?t=205451

CTRL+LeftClick does not work.

If I set my system to link lighting it does not put a effect in the lighting on the Hue menu in iCue, even tho it control the bulbs. So how can you remove it? If CTRL+LeftClick even worked, it would not work here too. Add do you expect users to remove it every time they switch there lighting option.

I think you need to add remove Hue device option, this will make many people happy.

 

I have attached a screenshot of my Hue integration not having any problems with the Lighting Link effects and selecting only the rooms I wish to have that effect used on. Now if you are referring to the SCENES feature/effects from the home menu in iCUE, then yes you cannot de-select individual rooms/devices and that is indeed the intended effect of the SCENES feature.

 

You can utilize the CTRL+LeftClick as detailed or you can utilize the Quick Lighting Zone feature available.

 

attachment.php?attachmentid=41642&stc=1&d=1625773195]

Hue-LightingLink.thumb.png.498d6da57c2ff84e0ef10d51e0f2cccd.png

Link to comment
Share on other sites

It might have these option, like I said, But they do not work. I will still light up the whole house. You can select it, but does not work. Needs to be fixed.

Also, if you enable link lighting with a Nexus iCue (turn on or off), you can not assign any rooms or anything, there is no option.

Link to comment
Share on other sites

  • 5 months later...

I have followed the instructions listed above, and deselected the rooms I do not want to be part of the programs/scenes(they were never actually part of the scenes I created to begin with, but I verified), so it won't change the other home lights to my created scenes, but whenever I log into my computer or change scenes,, it STILL changes every other light in the house from whatever setting each room is on, to "dim" mode.  It's quite annoying and in spite of following the instructions and verifying only the computer room is part of the scenes, it STILL turns every light in the house to "dim" mode.

I elected to disable hue integration until i get this straightened out.

 

Any thoughts or suggestions?

Edited by TeeRuddle
Typo
Link to comment
Share on other sites

  • 4 weeks later...

I think what's happening here is when iCue turns off the default/hardware color scheme in favor of the one it sets when you login, it turns off/down all lights it has access to including the Hue lights and then turns on the new scheme.
Which means when I boot my computer, every light in the house goes off - including my daughters bedrooms.
I set up the Hue hub, but I don't have any effects set up for any of my Hue lights in iCue presently and it still turns them off.
Please do not have iCue turn off Hue lights when it switches from the hardware scheme to the software scheme, otherwise this is basically a useless feature for those of us with hue lights in more than one room.
 

Link to comment
Share on other sites

  • 2 weeks later...

As a new Icue user I was very surprised and happy that I could add my Philips Hue bridge to the Icue software. But after spending an evening using it I have now sadly disabled it.

After reading this post and the reply's it seems that most users and me want to be able to exclude "roomes"(that are setup in the on the hue bridge) from the "Scenes" menu in the Icue software. I don't want to create "profiles" and I don't want to create  "lighting effects" and/or "layers" for every product I have connected to the Icue software. But what I do want is one button to set a scene for all the things I have connected to the software.... And that is what I thought the "Scenes" menu was for. Easy one click one scene for all the lights that I have allowed the software to control not EVERYTHING connected to my Hue Bridge.

Sadly this is not the only problem. I have more than one room with Philips Hue lights. Currently when I start the Icue software ALL the lights that are connected to my Hue bridge and are turned on, are turned off, and when I select a "Scene" all the lights that were on when I started the software are now included in the scene. Meaning that when I boot up my computer(in the office) the lights in the entrance, bedroom, livingroom and office are all turned off and then get included in the Scene when I choose a scene.

Please please fix these things. I would love that I with one click could set a "Scene" for the lights in my computer, my mouse, my keyboard and the Philips Hue lights in my office and all this without turning off or making every light in the rest of the house start blinking or changing color.

Link to comment
Share on other sites

  • 1 month later...
  • 1 month later...

This would be a cool integration if you could limit which devices / rooms / zones were integrated.
 

I have 47 devices on my indoor hue bridge,  and only 6 of those are in the room with my computer.  Renders a potentially cool feature unusable for me.  Doesn't seem like this would be a difficult feature to include.   Apparently just not a priority.

 

 

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...