Jump to content
Corsair Community

Commander Pro Ports Failing


KenArchie
 Share

Recommended Posts

Hello! So, recently I believe my fans ports to my commander pro are being destroyed for some reason. I have been using new corsair products for about 3 months now. Two weeks ago all three of my fans stopped working ( I have 3 fan splitter ), my response was to switch power ports on the commander pro. Switching did fix it, however, today the new port stopped working as well. So now 2 of my 6 fan ports don't work ( I tested the old one again ) . I'm afraid that I may have a faulty commander pro or maybe it cannot use a 3 fan splitter. The reason of me using 3 man splitter is because I have a full water cooling Corsair computer and I want to be able to control my RPM of my pump through iCue. Thank you for your time I really appreciate it! :)

 

The Cooling Kit : https://www.amazon.ca/gp/product/B08C7QJC7G/ref=ppx_yo_dt_b_asin_title_o01_s00?ie=UTF8&psc=1

 

Additional Fans : https://www.newegg.ca/corsair-co-9050092-ww-case-fan/p/N82E16835181168?item=N82E16835181168&source=region&nm_mc=knc-googleadwordsca-pc&cm_mmc=knc-googleadwordsca-pc-_-pla-_-case+fans-_-N82E16835181168&gclid=CjwKCAjwx6WDBhBQEiwA_dP8rTIlWDWTEUOLm_7_PvLC7p8MuSQIaTmcjQ78RFsIAv4IwCPXFMFcIRoCjcsQAvD_BwE

 

3 Pin Fan Splitter : https://www.amazon.ca/gp/product/B07PXLHNZ6/ref=ppx_yo_dt_b_asin_title_o02_s00?ie=UTF8&psc=1

Link to comment
Share on other sites

You should not use 3 or 4 way splitters on the Commander. Loss of control is the normal reaction and not a dead port, but at 0.90 of a 1.0A max it is still possible. See if the ports will respond to a single fan.

 

You can usually use a two way splitter, but if you have large numbers of fans to manage you will be better off using a powered PWM repeater hub rather than loading up the Commander to 12 fans.

Link to comment
Share on other sites

Hello, thank you for the really fast reply! I've tried plugging a single fan into the ports which wasn't working for the splitter. So I reset the commander pro, unplugging from SATA power then holding down the reset button, plugging back in and letting it blink. Then turned my pc back on, still not working. Then forced the commander pro with reinstalling the latest update. However, they still seem to be nulled. :( Do you think I should contact Corsair about the warranty and purchase 2 head fan splitters?

 

Thank you again for the reply!

Link to comment
Share on other sites

If they don’t respond to a single direct fan connection, I would contact Corsair Support. I don’t have any further steps to recommend beyond what you’ve already done.

 

Two way PWM splitters are generally safe and I have been using them on it for years. However, officially on 6 direct connection fans are supported. A PWM repeater hub is a safe way to offload fan motor current to another powered device. Do not load the Commander with high numbers of DC fans. This has caused problems for other users.

Link to comment
Share on other sites

 Share

×
×
  • Create New...