Jump to content
Corsair Community

AX1200i stop working, red light in on/off and PSU cannot start my PC


Recommended Posts

Hello everyone. I hope that you here can advise me, help me solve my problem with PSU. I purchased this AX1200i PSU in December 2015 from Newegg Canada. I did NOT have any problems with him until 2 days ago. It happened spontaneously after 1.5 hours of PC work. My PC then went off again and tried to start and did so several times. I tried to understand the problem, I reconnected to the PC and I tried to start it but without success. He tried again to turn it on and disconnected in 1-2 seconds. I opened the computer cover to see if there was any smell of smoke or burning. Everything was normal. I noticed that the red light was on at the PSU. When I try to turn on the PC, the bulb lights up for 1 second and looks green, then the color changes to red. It does this 3-4 times, and it doesn't start. I tried to disconnect all the cables, to check if the problem is in a short circuit, but it is not the problem in the cables but in the PSU. I only started the PSU alone, and when I press the control button the green light comes on for 1 second then it changes color to red, and so on.

I found on the official Corsair page this problem with PSU from certain series, I checked and my PSU is not part of that series.

Please help me who knows or who had such problems with this PSU. As mentioned above, I purchased this product from Newegg Canada. Today I contacted Newegg and they said I should contact Corsair. Please help me, because I have to fix this problem as soon as possible. On May 3, I start the spring semester at the university and I will have a great need for a PC:[pouts:.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...