Jump to content
Corsair Community

KATAR Pro KT not working after firmware update


Recommended Posts

hey i just bought Katar PRO KT mouse about 1 week ago , everything was working fine the mouse is good but then i opened icue software to change my dpi and i saw software update for Katar PRO on icue, then i have it updated but suddenly my mouse is not working after the update(mouse rgb on the scroll wheel is not on, i cant move the cursor or click anything,BUT i can see the sensor's light underneath the mouse), the app told me to replug the mouse but nothing happened after i do that, i tried to reinstall icue with clean install but the mouse still not working can somebody help me?

 

sorry for my bad english

  • Like 1
Link to comment
Share on other sites

  • 4 months later...

Hi there, i pretty gotten similar situation, as i just gotten my KATAR Pro KT like 2x days ago.

Saw the firmware update, during update, it shows "in progress 100% firmware update", and asked to "replug mouse".

So i followed that instruction and now my mouse not working at all...

Any remedy/solution for my newly bought mouse?

  • Like 1
Link to comment
Share on other sites

  • 1 month later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...