Jump to content
Corsair Community

VOID Pro Wireless dead after update?


Recommended Posts

Does anyone have any ideas what is going on since the latest Windows 10 update 20H2?

After the update, both my KGB100RGB keyboard and Ironclaw RGB mouse worked fine, but my Void Pro headset disappeared completely.

It wasn't in Device Manager, it's gone from the sound settings and is nowhere to be found in ICUE.

I've tried updating ICUE to 4.9.350, but it still won't recognise it.

The dongle won't light up on any USB port, I've checked it on another computer and it works absolutely fine, it installed itself, paired and was ready to go.

Back in my machine, it still won't recognise that there's anything in the USB port. Strangely, it now recognises my Vive pro headset as an audio device when it didn't before.

I'm going to try a rollback on my Windows 10 updates and see what happens, I only have a feeling that something in that update has done something very strange to my USB settings, unless anybody has any other ideas?

 

Edit: Rolled back my windows updates, still nothing. Reinstalled ICUE as per Corsair's instructions, no difference. I'm at a loss. For some reason, USB will not recognise the dongle anymore, which continues to work fine in other machines.

I'm more or less convinced that it's a USB driver issue, which is why replacing the dongle may prove useless in this case.

 

Edit#2: Yep, I was right. One of the USBRootHub drivers was corrupted. AVG's driver updater caught it and installed the correct one. Thank Christ for that! :D

Edited by Knives139
updating progress
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...