Jump to content
Corsair Community

Having trouble with SP 120 fans in new 570X case


Recommended Posts

I just bought a used SP 120 case fan so I would have 4 in my new 570X case. It will only light up white, and will not synchronize with the other fans. I checked the model number and it matches the others, RWF0016. I tried plugging it into the fan hub in the 4, 1, and 3 positions. If plugged into the 1 position then 2 and 3 are dark. Is the fan broken or is something else wrong?
Link to comment
Share on other sites

It appears there is a defect in the new fan. The lighting works in series, so if it is misbehaving when on the end in the #4 slot and then knocks out the fans after it in the #1 slot, it mostly likely has a problem. I would contact the vendor for a replacement or you can do the same through Corsair if the vendor is non-responsive. Make sure you are getting "SP120-RGB fans" and not SP-Pro or SP-Elite. Those will not work together.
Link to comment
Share on other sites

It matches the model number of my other SP 120 fans so it doesn't seem to be an issue with the type of fan. The guy I bought it from claims that it worked ok for him but he also says he was using iCue which I don't think works with these fans.
Link to comment
Share on other sites

Ok, so return/warranty is not going to be an option. Are you using the thumb remote controller to operate them? They do work with CUE, but you need a Lighting Node Pro, Core, or Commander to integrate them. Regardless it should work on the thumb remote as well.
Link to comment
Share on other sites

Yes I'm using the 3 button controller that comes with the 570x case. Is there any way to get it working? Is it not working because it was previously used with a Corsair Pro Controller? I also have an h110i, can I plug the fan in to that and reset it somehow?
Link to comment
Share on other sites

No, the memory for hardware settings is in the device, not the fan. That should not matter.

 

What you were doing originally is the right troubleshooting path. If you stick the new fan in port 4 and it misbehaves, then you move it to port 1 and the fans after it misbehave, it seems highly likely there is a problem with the fan. You can further demonstrate this by using the 3 originals in 1-2-3 only (should work) and also running the new fan in port 1 with no other fan connected (should probably misbehave). Unfortunately this is an internal LED issue and not something easily repaired. What you want to rule out right now is the 6 port hub itself. I think you've done that since 2+3 work fine when new fan is in #4, but then do not work when new fan goes to 1. You can further implicate the new fan by moving it 2 and 3 and it should knock out the fan after.

Link to comment
Share on other sites

  • Corsair Employees
Yes I'm using the 3 button controller that comes with the 570x case. Is there any way to get it working? Is it not working because it was previously used with a Corsair Pro Controller? I also have an h110i, can I plug the fan in to that and reset it somehow?

 

What exact fan did you purchase? If you you purchased an SP120 RGB Pro/Elite fan that is not compatible with the 3-button controller used on the 570x RGB to control the original SP120 RGB fans. The new Pro/Elite fans are ARGB LEDs and will not work with the controller.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...