Jump to content
Corsair Community

Corsair Lighting Hub disables my SSDs


Zephyr28
 Share

Recommended Posts

In addition to my specs above, I have the Corsair H100i AIO with a 240mm radiator and 3 additional case fans.

 

After installing the Corsair Lighting Node Pro and RGB Fan Hub, my 2 SSDs are no longer recognized by my BIOS.

 

At first I thought I may have been overloading my SATA power cable, but after further troubleshooting, I've determined that if either of the two Corsair devices (the LNP or hub) are connected to any SATA power connection, the SSDs will not be recognized.

 

To confirm this, I disconnected my HDD, both Corsair devices, and one SSD from their SATA cables and booted into my BIOS. The connected SSD was there.

 

I plugged in just one of the Corsair devices to a separate SATA cable and restarted; the SSD was not recognized again. So it seems if either of those devices is powered at all, the SSDs are not.

 

Has anyone else had this issue and/or know how I can fix it?

Link to comment
Share on other sites

That's super tricky to diagnose all right.

The only thing I can think of is maybe try a different mb header for the Commander's USB connection and see if the problem follows it there also.

 

I switched the USB to another MB header and the issue seemed to be resolved when only the RGB hub was connected to SATA. However, when I hooked up the LNP to SATA, the SSDs disappeared again.

 

So I tried again, with neither device connected and the SSDs still didn't show. I tried removing the USB connection from my MB altogether and SSDs were back.

 

Leaving the USB disconnected, I again connected just the LNP to SATA and again the SSDs were not recognized.

 

I am very confused now. I would say it could be a power issue, except that just having the USB connected (without power) now causes the issue too. I cannot fathom how the USB or SATA for the Corsair fans should affect my SSDs in any way.

Edited by Zephyr28
Link to comment
Share on other sites

Well none of these devices are high speed enough to be the recent "Global C State" thing but it does seem vaguely similar. Sorry, out of ideas here except maybe check the MB manufacturer for the latest BIOS?

 

Yeah, I've already got the latest BIOS. I have a Commander Pro on order too so I may try switching out the hub for that instead (I think that's what it replaces).

 

Thank you for the ideas, though.

Link to comment
Share on other sites

This is likely related to the AGESA microcode.

 

https://hothardware.com/news/amd-agesa-1202-ryzen-usb-connectivity-concerns

https://www.pcmag.com/news/amd-locates-root-cause-of-usb-issues-on-b550-x570-motherboards

 

ASUS released BIOS updates just four days ago for most of their x570 and B550 boards. You might check your Mobo MFR site for latest BIOS containing AGESA 1.2.0.2 for your USB/SATA disconnect issues.

 

Good luck!

Link to comment
Share on other sites

 Share

×
×
  • Create New...