Jump to content
Corsair Community

Does v3.38.61 fix the freezing caused by icue interaction process?


johnnydotexe
 Share

Recommended Posts

There are a small handful of reports out there of people, including me, having their computers freeze up and act weird which is fixed by killing the "icue service for interfaction with corsairllaccess driver (32bit)" process. For me the issue has been happening since the last iCue release.

 

Has this issue been acknowledged by Corsair, and if so, was it fixed in this new release?

 

Bonus Question: I have a K95 RGB, Corsair Void Pro RGB, and Corsair H80i. I'm running iCue + Link. Why do I need two applications from Corsair to control/monitor all these devices, can I just use one application? FWIW, I haven't been able to figure out how to get iCue to see or interact with my H80i so I'm assuming that's a "no."

Edited by johnnydotexe
Link to comment
Share on other sites

i have no clue BUT after years of not using iCue i just figured i'd try their latest 3.xx version that they just released and still supports my corsair gear, like a usb void headset.

Well, great thing it now actually seems to work like it should after all those years for me.

Just a shame i can't try the new 4 version now. Maybe that's for the best also.

I don't wanna go through all of the crap again of having gear you can't use the gizmos and features from.

Link to comment
Share on other sites

Just had another video/windows explorer lock up that was resolved by quickly killing the icue interaction process, so the latest version of iCue did not resolve the problem.

 

When is Corsair going to acknowledge this? It has been affecting multiple people.

Link to comment
Share on other sites

  • Corsair Employees
Your issue is most likely caused by attempting to run but iCUE and LINK together. They are not compatible with eachother and will conflict causing similar issues like you are experiencing. Based on the products you stated you have there should be no need to run LINK at all.
Link to comment
Share on other sites

Your issue is most likely caused by attempting to run but iCUE and LINK together. They are not compatible with eachother and will conflict causing similar issues like you are experiencing. Based on the products you stated you have there should be no need to run LINK at all.

 

For several years now I've wanted to run just one software for all my Corsair peripherals, but iCue doesn't see my H80i. It only shows my K95 RGB and Void Pro, so I've kept Link in order to manage and monitor my cooler.

 

Is there a way to get iCue v3 to see and manage my cooler?

Link to comment
Share on other sites

  • Corsair Employees

If the H80i you have is the one linked below unfortunately no you will not be able to use it in iCUE. But the issue you are experiencing is most likely from running both LINK and iCUE together. Unfortunately you will need to be willing to choose one as the main software to run at all times while only opening the other when you need to change something. Mainly you need to be willing to just set the performance mode for your cooler in LINK and then close it. The cooler will continue to run without issues. If you wish to be able to monitor CPU temps then you can use the iCUE dashboard for that.

 

https://www.corsair.com/us/en/Categories/Products/Liquid-Cooling/Hydro-Series%E2%84%A2-H80i-High-Performance-Liquid-CPU-Cooler/p/CW-9060008-WW

 

If the H80i you are referring to is the V2 variant it will work with iCUE.

Link to comment
Share on other sites

If the H80i you have is the one linked below unfortunately no you will not be able to use it in iCUE. But the issue you are experiencing is most likely from running both LINK and iCUE together. Unfortunately you will need to be willing to choose one as the main software to run at all times while only opening the other when you need to change something. Mainly you need to be willing to just set the performance mode for your cooler in LINK and then close it. The cooler will continue to run without issues. If you wish to be able to monitor CPU temps then you can use the iCUE dashboard for that.

 

https://www.corsair.com/us/en/Categories/Products/Liquid-Cooling/Hydro-Series%E2%84%A2-H80i-High-Performance-Liquid-CPU-Cooler/p/CW-9060008-WW

 

If the H80i you are referring to is the V2 variant it will work with iCUE.

 

I do have the v1 version of the h80i.

 

I closed Corsair LINK and set it to not auto-start with Windows. I should know within a few days if this resolves the issue or not.

Link to comment
Share on other sites

 Share

×
×
  • Create New...