Jump to content
Corsair Community

Issues with the ICUE H100i Pro XT?


Recommended Posts

Does anyone else have problems with the cooler disconnecting (with a USB disconnect sound that follows) and then reconnecting within a few seconds? This problem has happened to me a few times and I've noticed it happens when I do a fresh boot of my pc/restart it, when I try to stream on discord, or just at random times during the day. It doesn't happen everyday however. I've looked everywhere on google and can't seem to find any solution for the pro xt, just for other coolers. I've heard that issues like this could damage the aio pump so I really want to get this fixed as I really don't want to buy a new/different cooler.

 

 

 

I'm using the stock fans that come with the cooler, a 5800x, an Asus tuf oc 3080, a 850w power supply from gigabyte, and a Asus B550-f Gaming motherboard (without wifi). I have Armoury crate and ICUE installed. I have hwinfo installed, but have corsair link turned off. The CPU fan header is set at 100% PWM with Q-fan control disabled and so is the aio pump with the acceptation that it's set at DC. I have USB selective suspend settings disabled. I'm not using any other corsair products other than the pump itself.

 

I appreciate any help and info you can lend me, thank you :)

Link to comment
Share on other sites

  • Corsair Employees

Hello there, this does appear to be the AMD USB Disconnect issue. There is a planned AGESA update by AMD set for a mid-April release. Meaning it may show up in Bios Updates around the end of April/Early May.

 

Do you have Corsair Link installed? If so I suggest fully removing it, not just having it closed

Link to comment
Share on other sites

  • 2 weeks later...
Hello there, this does appear to be the AMD USB Disconnect issue. There is a planned AGESA update by AMD set for a mid-April release. Meaning it may show up in Bios Updates around the end of April/Early May.

 

Do you have Corsair Link installed? If so I suggest fully removing it, not just having it closed

 

Corsair Link is ICUE correct?

Link to comment
Share on other sites

No, Corsair Link is not iCUE (CUE 3). Link was the control program for internal devices before it was merged with the external peripherals program CUE. It was replaced 3 years ago before the release of XT coolers. I doubt Link would recognize one and it may cause control issues with CUE.

 

CUE 4 has just been released as the replacement for CUE 3. Both programs should control the XT.

Edited by c-attack
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...