Jump to content
Corsair Community

Unable to power up a B450 Aorus Elite Board using a Corsair CX750F Power Supply


Recommended Posts

Guys, can someone please help as I'm starting to get peed off.

 

I have a Gigabyte B450 Aorus Elite Board with a Ryzen 2700x I have just purchased a Corsair CX750F PSU, I've plugged it all in and nothing, the system just does not power on. At first the rgb flashes on the board but that's all it does.

 

One thing I've noticed that on my old PSU (Ambiance Bronze 750w) the cpu cable is a 4+4 but on the new PSU (Modular) it's just an 8 cable

 

This is what it says in the motherboard manual:-

 

ATX_12V/ATX (2x4 12V Power Connector and 2x12 Main Power Connector)

With the use of the power connector, the power supply can supply enough stable power to all the components

on the motherboard. Before connecting the power connector, first make sure the power supply is turned

off and all devices are properly installed. The power connector possesses a foolproof design. Connect the

power supply cable to the power connector in the correct orientation.

The 12V power connector mainly supplies power to the CPU. If the 12V power connector is not connected,

the computer will not start.

 

Should this cause a problem or shouldn't it matter.

 

I've 2 different cpu 8 modular cables that came with the new PSU but I just can't get it to work

 

Help!!!

Edited by aide199L1verpoo
Link to comment
Share on other sites

  • Corsair Employees

You're not using any of the old cables with the new PSU, are you?

 

All the cables that came with the PSU need to be used unless the old PSU was a Corsair PSU with Type 4 cables. That includes SATA, Molex, etc.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...