Jump to content
Corsair Community

Virtuoso SE Battery Issues


Recommended Posts

My Virtuoso SE can't maintain a charge. I've tried plugging it in with different cords and different sockets for hours at a time, and it won't stay on for longer than a few seconds. I've tried higher voltage connections, like wall sockets and fast charge USB. They work better but not enough.

 

When I plug it in, the light next to the USB slow blinks red and never changes. The USB mode does not work when plugged in, and the Wireless mode only works for a few seconds. When unplugged, iCue reads the power levels of the battery as "Critical".

 

I was having no problems with the headset before this issue, with no noticeable decay in charged time. I am currently using it by plugging in the USB and utilizing the mini jack, which is not optimal.

 

Please advise, thanks.

Link to comment
Share on other sites

  • Corsair Employees

Try the steps below. If that doesn't resolve the issue reach out to our support team by opening a ticket at https://help.corsair.com

 

1. Make sure your headset is unplugged and set to the wireless mode.

2. Hold the Mute button on the headset down for about 20 seconds

3. After holding the Mute button, toggle the headset to the USB mode then back to Wireless.

 

Once you have done the above steps leave the headset plugged in to charge for at least an hour before testing.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...