Jump to content
Corsair Community

iCUE not detecting K95 after sleep


Recommended Posts

Hi!

I ran into a new problem yesterday.

When I got home from work, I woke up my PC (I always put it to sleep when I go to bed), and logged in.

But this time, the colors on my K95 were still White and Red (as they are when PC is sleeping)

 

I found this weird and began to investigate.

In iCUE, it detect my mouse (Corsair Glaive) and my motherboard (ASUS), but it does not detect K95

If I quit iCUE and start it again, it still wont work.

Disconnecting the keyboard and put it back in, it works

after reboot it works.

 

So the keyboard is working, but not after Sleep.

Does anyone have any idea? iCUE is updated, drivers are updated, windows is updated, bios is updated etc.

It has worked for 2 years, but suddenly, it doesnt anymore

 

And also, while K95 is not detected, iCUE is very slow and almost unresponsive. just opening the GUI takes 30 seconds.

If K95 is detected, it is fast again.

Link to comment
Share on other sites

  • Corsair Employees

Hi there,

 

iCUE can get bogged down sometimes especially after multiple installations, and needs a clean reinstall from time to time.

 

Go ahead and perform a clean reinstall of iCUE using the steps below:

https://help.corsair.com/hc/en-us/articles/360025166712-Perform-a-clean-reinstallation-of-the-Corsair-Utility-Engine-iCUE-

 

If this doesn't help, please open up a ticket with support using the link at the top of the page, and reference this forum link in the post for best assistance.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...