Jump to content
Corsair Community

corsair virtuoso se connection problems


Recommended Posts

Hi

i have problems using my virtuoso headset wireless

it wont show up in windows(device manager) when the problem comes

 

i think it started after a windows update some weeks ago, and it seems to hit the pc's that did not have icue installed. the headset workes with usb cable.

Some times when i get it to work it can work for 2-5 min before disappearing again..

 

icue says firmware is 0.17.149 and 0.16.80

 

i have tried:

different usb port

installing icue

resetting the headset with the button

uninstalling windows updates ( dongle does not work from my phone either..)

uninstalling usb devices in device manager

uninstalling every corsair thing in device manager

 

any adivce? thanks

Edited by NorKris
Link to comment
Share on other sites

  • Corsair Employees
Hi

i have problems using my virtuoso headset wireless

it wont show up in windows(device manager) when the problem comes

 

i think it started after a windows update some weeks ago, and it seems to hit the pc's that did not have icue installed. the headset workes with usb cable.

Some times when i get it to work it can work for 2-5 min before disappearing again..

 

icue says firmware is 0.17.149 and 0.16.80

 

i have tried:

different usb port

installing icue

resetting the headset with the button

uninstalling windows updates ( dongle does not work from my phone either..)

uninstalling usb devices in device manager

uninstalling every corsair thing in device manager

 

any adivce? thanks

 

Hi NorKris,

 

When you say the headset works for 2-5 min before disappearing, is this via wired or wireless connection? Can you try re-pairing the wireless dongle to the headset via iCUE to see if there are any improvements?

Link to comment
Share on other sites

Corsair has a new icue beta out. It will likely address your issues. Unfortunately that wireless radio is impacted by the slipstream multipoint non existent beta.

 

See the following

 

 

Request access to the beta by using the link in the message on the reddit post. Its just a support ticket.

Link to comment
Share on other sites

Hi NorKris,

 

When you say the headset works for 2-5 min before disappearing, is this via wired or wireless connection? Can you try re-pairing the wireless dongle to the headset via iCUE to see if there are any improvements?

 

some times when im lucky the headset can work wires for 2-15min some times more but then completely random it drops out.

 

i have no problems what so ever with wired connection

Link to comment
Share on other sites

Corsair has a new icue beta out. It will likely address your issues. Unfortunately that wireless radio is impacted by the slipstream multipoint non existent beta.

 

See the following

 

 

Request access to the beta by using the link in the message on the reddit post. Its just a support ticket.

 

 

yeah well i dont know. cant rly install icue on my phone :P

Link to comment
Share on other sites

Hi NorKris,

 

When you say the headset works for 2-5 min before disappearing, is this via wired or wireless connection? Can you try re-pairing the wireless dongle to the headset via iCUE to see if there are any improvements?

 

re-pairing did nothing :(

Link to comment
Share on other sites

  • Corsair Employees
re-pairing did nothing :(

 

Can you try doing a soft reset on your VIRTUOSO headset to see if it will address your issue?

 

To soft reset your headset:

1. Make sure your headset is currently unplugged.

2. Make sure your headset is powered on.

3. Hold the Mute button on the headset down for about 15 seconds.

4. Switch the headset off and then back on.

5. Test your headset and see if the issue is resolved.

 

If this does not help, please open a ticket at https://help.corsair.com and our support will take care of you.

Link to comment
Share on other sites

Can you try doing a soft reset on your VIRTUOSO headset to see if it will address your issue?

 

To soft reset your headset:

1. Make sure your headset is currently unplugged.

2. Make sure your headset is powered on.

3. Hold the Mute button on the headset down for about 15 seconds.

4. Switch the headset off and then back on.

5. Test your headset and see if the issue is resolved.

 

If this does not help, please open a ticket at https://help.corsair.com and our support will take care of you.

 

it tryed that. but the problem is not on the headset side..

 

if the dongle failes to connect to the headset its still visible in windows.. mine are not

Link to comment
Share on other sites

Sounds like you might be running an AMD system?

 

https://www.pcmag.com/news/amd-locates-root-cause-of-usb-issues-on-b550-x570-motherboards

 

If so, update your BIOS containing the latest AGESA version.

 

ASUS just released new BIOS for most X570 and B550 boards on 3/22/2021. It is 3/26/2021 today.

 

I have been battling audio crackling issues for almost 9 months. I updated to latest BIOS for my ASUS TUF X570 Gaming WiFi today and my crackling issue is fixed. Hopefully for good!

Link to comment
Share on other sites

Sounds like you might be running an AMD system?

 

https://www.pcmag.com/news/amd-locates-root-cause-of-usb-issues-on-b550-x570-motherboards

 

If so, update your BIOS containing the latest AGESA version.

 

ASUS just released new BIOS for most X570 and B550 boards on 3/22/2021. It is 3/26/2021 today.

 

I have been battling audio crackling issues for almost 9 months. I updated to latest BIOS for my ASUS TUF X570 Gaming WiFi today and my crackling issue is fixed. Hopefully for good!

 

Did u type in wrong thread?

Link to comment
Share on other sites

Did u type in wrong thread?

 

 

I am trying to get the word out to people that updating the BIOS to the latest AGESA version (for AMD systems) can help tremendously with audio crackling AND.....oooo guess what - USB disconnect issues.

 

By the way, the disconnect issue can kill USB devices. Mine killed my mouse.

Link to comment
Share on other sites

I am trying to get the word out to people that updating the BIOS to the latest AGESA version (for AMD systems) can help tremendously with audio crackling AND.....oooo guess what - USB disconnect issues.

 

By the way, the disconnect issue can kill USB devices. Mine killed my mouse.

 

ah ok. My CPUs are

i9 7940x

i7 7700HQ

i7 8550u

Snapdragon 865

 

None if them work

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...