Jump to content
Corsair Community

H115i PRO XT pump not working


Recommended Posts

Got my AIO today, finished installing it but seems like the pump is not working. The RGB of said pump worked for a bit, but when I got my first hard freeze because of cpu TEMP it stopped working.

 

Installed the USB to a usb header on the mb

Installed the SATA power cable of the pump to a free SATA and then tried one that was previously connected to a harddrive

Installed the 1pin tachometer header to the pump header on the MB

Installed both fans to the fan headers of the pump.

 

Fans work (At max speed always) but the pump doesn't seem to be working,I'm getting freezes because of high cpu temps

 

MB: Z390 gigabyte aorus elite

PSU: Gibabyte G750H

 

I'm currenly waiting for the retailer to follow through but it can take some time.

 

Any thoughts?

16147892541676228154099785619419.thumb.jpg.6725990e064a25026c5d7e2039bdc1bd.jpg

1614789299139219774114453350964.thumb.jpg.1d57b0aa613b90b83bc5c8f17d67cce5.jpg

16147893300393176684755862988894.thumb.jpg.6dce493bffcd460845dea8e21d01a97c.jpg

Capture.thumb.PNG.eba0b95d2585d7216d6d772f09667585.PNG

16147893443071922684144124651839.thumb.jpg.13f8b8b1bf5be86feb56a2a89549c4a2.jpg

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...